DragonFly On-Line Manual Pages

Search: Section:  


DEVICE_DETACH(9)      DragonFly Kernel Developer's Manual     DEVICE_DETACH(9)

NAME

DEVICE_DETACH -- detach a device

SYNOPSIS

#include <sys/param.h> #include <sys/bus.h> int DEVICE_DETACH(device_t dev);

DESCRIPTION

Detach a device. This can be called if the user is replacing the driver software or if a device is about to be physically removed from the system (e.g. for pccard devices). The method should deallocate any system resources allocated during the DEVICE_ATTACH(9) method and reset the hardware to a sane state (i.e. dis- able interrupts etc.)

RETURN VALUES

Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO

device(9), DEVICE_ATTACH(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.5 June 16, 1998 DragonFly 3.5

Search: Section: