DragonFly On-Line Manual Pages

Search: Section:  


ARCHIVE(8)                InterNetNews Documentation                ARCHIVE(8)

NAME

archive - Usenet article archiver

SYNOPSIS

archive [-cfr] [-a archive] [-i index] [-p pattern] [input]

DESCRIPTION

archive makes copies of files specified on its standard input. It is normally run either as a channel feed under innd or by a script before news.daily is run. archive reads the named input file, or standard input if no file is given. The input is taken as a sequence of lines; blank lines and lines starting with a number sign ("#") are ignored. All other lines should specify the token of an article to archive. Every article is retrieved from a token, and the Xref: header is used to determine the target file in the archive directory. You can limit the targets taken from the Xref: header with the -p option. Files are copied to a directory within the archive directory, patharchive in inn.conf (or some other directory given with -a). The default is to create a hierarchy that mimics a traditional news spool storage of the given articles; intermediate directories will be created as needed. For example, if the input token represents article 2211 in the newsgroup comp.sources.unix, archive will by default store the article as: comp/sources/unix/2211 in the archive area. This can be modified with the -c and -f options.

OPTIONS

-a archive If the -a flag is given, its argument specifies the root of the archive area, instead of patharchive in inn.conf. -c If the -c flag is given, directory names will be flattened as described under the -f option. Then, additionally, all posts will be concatenated into a single file, appending to that file if it already exists. The file name will be "YYYYMM", formed from the current time when archive is run. In other words, if given an article in comp.sources.unix on December 14th, 1998, the article would be appended to the file: comp.sources.unix/199812 in the archive area. Articles will be separated by a line containing only "-----------". -f If the -f flag is used, directory names will be flattened, replacing the slashes with the periods. In other words, article 2211 in comp.sources.unix will be written to: comp.sources.unix/2211 in the archive area. -i index If the -i flag is used, archive will append one line to the file index for each article that it archives. This line will contain the destination file name, the Message-ID: header, and the Subject: header of the message, separated by spaces. If either header is missing (normally not possible if the article was accepted by innd), it will be replaced by "<none>". The headers will be transformed using the same rules as are used to generate overview data (unfolded and then with tabs, CR, and LF replaced by spaces). -p pattern Limits the targets taken from the Xref: header to the groups specified in pattern. pattern is a uwildmat(3) pattern matching newsgroups that you wish to have archive handle. -r By default, archive sets its standard error to pathlog/errlog. To suppress this redirection, use the -r flag.

RETURN VALUE

If the input is exhausted, archive will exit with a zero status. If an I/O error occurs, it will try to spool its input, copying it to a file. If there was no input filename, the standard input will be copied to pathoutgoing/archive and the program will exit. If an input filename was given, a temporary file named input.bch (if input is an absolute pathname) or pathoutgoing/input.bch (if the filename does not begin with a slash) is created. Once the input is copied, archive will try to rename this temporary file to be the name of the input file, and then exit.

EXAMPLES

A typical newsfeeds(5) entry to archive most source newsgroups is as follows: source-archive!\ :!*,*sources*,!*wanted*,!*.d\ :Tc,Wn\ :<pathbin>/archive -f -i <patharchive>/INDEX Replace <pathbin> and <patharchive> with the appropriate paths.

HISTORY

Written by Rich $alz <rsalz@uunet.uu.net> for InterNetNews. Converted to POD by Russ Allbery <eagle@eyrie.org>. $Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $

SEE ALSO

inn.conf(5), newsfeeds(5). INN 2.6.0 2015-09-12 ARCHIVE(8) ARCHIVE_READ_OPEN(3) DragonFly Library Functions Manual ARCHIVE_READ_OPEN(3)

NAME

archive_read_open, archive_read_open2, archive_read_open_fd, archive_read_open_FILE, archive_read_open_filename, archive_read_open_memory - functions for reading streaming archives

LIBRARY

Streaming Archive Library (libarchive, -larchive)

SYNOPSIS

#include <archive.h> int archive_read_open(struct archive *, void *client_data, archive_open_callback *, archive_read_callback *, archive_close_callback *); int archive_read_open2(struct archive *, void *client_data, archive_open_callback *, archive_read_callback *, archive_skip_callback *, archive_close_callback *); int archive_read_open_FILE(struct archive *, FILE *file); int archive_read_open_fd(struct archive *, int fd, size_t block_size); int archive_read_open_filename(struct archive *, const char *filename, size_t block_size); int archive_read_open_memory(struct archive *, const void *buff, size_t size);

DESCRIPTION

archive_read_open() The same as archive_read_open2(), except that the skip callback is assumed to be NULL. archive_read_open2() Freeze the settings, open the archive, and prepare for reading entries. This is the most generic version of this call, which accepts four callback functions. Most clients will want to use archive_read_open_filename(), archive_read_open_FILE(), archive_read_open_fd(), or archive_read_open_memory() instead. The library invokes the client-provided functions to obtain raw bytes from the archive. archive_read_open_FILE() Like archive_read_open(), except that it accepts a FILE * pointer. This function should not be used with tape drives or other devices that require strict I/O blocking. archive_read_open_fd() Like archive_read_open(), except that it accepts a file descriptor and block size rather than a set of function pointers. Note that the file descriptor will not be automatically closed at end-of-archive. This function is safe for use with tape drives or other blocked devices. archive_read_open_file() This is a deprecated synonym for archive_read_open_filename(). archive_read_open_filename() Like archive_read_open(), except that it accepts a simple filename and a block size. A NULL filename represents standard input. This function is safe for use with tape drives or other blocked devices. archive_read_open_memory() Like archive_read_open(), except that it accepts a pointer and size of a block of memory containing the archive data. A complete description of the struct archive and struct archive_entry objects can be found in the overview manual page for libarchive(3).

CLIENT CALLBACKS

The callback functions must match the following prototypes: typedef la_ssize_t archive_read_callback(struct archive *, void *client_data, const void **buffer) typedef la_int64_t archive_skip_callback(struct archive *, void *client_data, off_t request) typedef int archive_open_callback(struct archive *, void *client_data) typedef int archive_close_callback(struct archive *, void *client_data) The open callback is invoked by archive_open(). It should return ARCHIVE_OK if the underlying file or data source is successfully opened. If the open fails, it should call archive_set_error() to register an error code and message and return ARCHIVE_FATAL. The read callback is invoked whenever the library requires raw bytes from the archive. The read callback should read data into a buffer, set the const void **buffer argument to point to the available data, and return a count of the number of bytes available. The library will invoke the read callback again only after it has consumed this data. The library imposes no constraints on the size of the data blocks returned. On end-of-file, the read callback should return zero. On error, the read callback should invoke archive_set_error() to register an error code and message and return -1. The skip callback is invoked when the library wants to ignore a block of data. The return value is the number of bytes actually skipped, which may differ from the request. If the callback cannot skip data, it should return zero. If the skip callback is not provided (the function pointer is NULL ), the library will invoke the read function instead and simply discard the result. A skip callback can provide significant performance gains when reading uncompressed archives from slow disk drives or other media that can skip quickly. The close callback is invoked by archive_close when the archive processing is complete. The callback should return ARCHIVE_OK on success. On failure, the callback should invoke archive_set_error() to register an error code and message and return ARCHIVE_FATAL.

RETURN VALUES

These functions return ARCHIVE_OK on success, or ARCHIVE_FATAL.

ERRORS

Detailed error codes and textual descriptions are available from the archive_errno() and archive_error_string() functions.

SEE ALSO

tar(1), archive_read(3), archive_read_data(3), archive_read_filter(3), archive_read_format(3), archive_read_set_options(3), archive_util(3), libarchive(3), tar(5) DragonFly 5.9-DEVELOPMENT February 2, 2012 DragonFly 5.9-DEVELOPMENT

Search: Section: