DragonFly On-Line Manual Pages

Search: Section:  


ARCHIVE(8)                InterNetNews Documentation                ARCHIVE(8)

NAME

archive - Usenet article archiver

SYNOPSIS

archive [-cfr] [-a archive] [-i index] [-p pattern] [input]

DESCRIPTION

archive makes copies of files specified on its standard input. It is normally run either as a channel feed under innd or by a script before news.daily is run. archive reads the named input file, or standard input if no file is given. The input is taken as a sequence of lines; blank lines and lines starting with a number sign ("#") are ignored. All other lines should specify the token of an article to archive. Every article is retrieved from a token, and the Xref: header is used to determine the target file in the archive directory. You can limit the targets taken from the Xref: header with the -p option. Files are copied to a directory within the archive directory, patharchive in inn.conf (or some other directory given with -a). The default is to create a hierarchy that mimics a traditional news spool storage of the given articles; intermediate directories will be created as needed. For example, if the input token represents article 2211 in the newsgroup comp.sources.unix, archive will by default store the article as: comp/sources/unix/2211 in the archive area. This can be modified with the -c and -f options.

OPTIONS

-a archive If the -a flag is given, its argument specifies the root of the archive area, instead of patharchive in inn.conf. -c If the -c flag is given, directory names will be flattened as described under the -f option. Then, additionally, all posts will be concatenated into a single file, appending to that file if it already exists. The file name will be "YYYYMM", formed from the current time when archive is run. In other words, if given an article in comp.sources.unix on December 14th, 1998, the article would be appended to the file: comp.sources.unix/199812 in the archive area. Articles will be separated by a line containing only "-----------". -f If the -f flag is used, directory names will be flattened, replacing the slashes with the periods. In other words, article 2211 in comp.sources.unix will be written to: comp.sources.unix/2211 in the archive area. -i index If the -i flag is used, archive will append one line to the file index for each article that it archives. This line will contain the destination file name, the Message-ID: header, and the Subject: header of the message, separated by spaces. If either header is missing (normally not possible if the article was accepted by innd), it will be replaced by "<none>". The headers will be transformed using the same rules as are used to generate overview data (unfolded and then with tabs, CR, and LF replaced by spaces). -p pattern Limits the targets taken from the Xref: header to the groups specified in pattern. pattern is a uwildmat(3) pattern matching newsgroups that you wish to have archive handle. -r By default, archive sets its standard error to pathlog/errlog. To suppress this redirection, use the -r flag.

RETURN VALUE

If the input is exhausted, archive will exit with a zero status. If an I/O error occurs, it will try to spool its input, copying it to a file. If there was no input filename, the standard input will be copied to pathoutgoing/archive and the program will exit. If an input filename was given, a temporary file named input.bch (if input is an absolute pathname) or pathoutgoing/input.bch (if the filename does not begin with a slash) is created. Once the input is copied, archive will try to rename this temporary file to be the name of the input file, and then exit.

EXAMPLES

A typical newsfeeds(5) entry to archive most source newsgroups is as follows: source-archive!\ :!*,*sources*,!*wanted*,!*.d\ :Tc,Wn\ :<pathbin>/archive -f -i <patharchive>/INDEX Replace <pathbin> and <patharchive> with the appropriate paths.

HISTORY

Written by Rich $alz <rsalz@uunet.uu.net> for InterNetNews. Converted to POD by Russ Allbery <eagle@eyrie.org>. $Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $

SEE ALSO

inn.conf(5), newsfeeds(5). INN 2.6.0 2015-09-12 ARCHIVE(8) ARCHIVE_READ_OPTIONS(3) DragonFly Library Functions Manual

NAME

archive_read_set_filter_option, archive_read_set_format_option, archive_read_set_option, archive_read_set_options - functions controlling options for reading archives

LIBRARY

Streaming Archive Library (libarchive, -larchive)

SYNOPSIS

#include <archive.h> int archive_read_set_filter_option(struct archive *, const char *module, const char *option, const char *value); int archive_read_set_format_option(struct archive *, const char *module, const char *option, const char *value); int archive_read_set_option(struct archive *, const char *module, const char *option, const char *value); int archive_read_set_options(struct archive *, const char *options);

DESCRIPTION

These functions provide a way for libarchive clients to configure specific read modules. archive_read_set_filter_option(), archive_read_set_format_option() Specifies an option that will be passed to currently-registered filters (including decompression filters) or format readers. If option and value are both NULL, these functions will do nothing and ARCHIVE_OK will be returned. If option is NULL but value is not, these functions will do nothing and ARCHIVE_FAILED will be returned. If module is not NULL, option and value will be provided to the filter or reader named module. The return value will be that of the module. If there is no such module, ARCHIVE_FAILED will be returned. If module is NULL, option and value will be provided to every registered module. If any module returns ARCHIVE_FATAL, this value will be returned immediately. Otherwise, ARCHIVE_OK will be returned if any module accepts the option, and ARCHIVE_FAILED in all other cases. archive_read_set_option() Calls archive_read_set_format_option(), then archive_read_set_filter_option(). If either function returns ARCHIVE_FATAL, ARCHIVE_FATAL will be returned immediately. Otherwise, greater of the two values will be returned. archive_read_set_options() options is a comma-separated list of options. If options is NULL or empty, ARCHIVE_OK will be returned immediately. Calls archive_read_set_option() with each option in turn. If any archive_read_set_option() call returns ARCHIVE_FATAL, ARCHIVE_FATAL will be returned immediately. Individual options have one of the following forms: option=value The option/value pair will be provided to every module. Modules that do not accept an option with this name will ignore it. option The option will be provided to every module with a value of "1". !option The option will be provided to every module with a NULL value. module:option=value, module:option, module:!option As above, but the corresponding option and value will be provided only to modules whose name matches module.

OPTIONS

Format cab hdrcharset The value is used as a character set name that will be used when translating file names. Format cpio compat-2x Libarchive 2.x incorrectly encoded Unicode filenames on some platforms. This option mimics the libarchive 2.x filename handling so that such archives can be read correctly. hdrcharset The value is used as a character set name that will be used when translating file names. pwb When reading a binary CPIO archive, assume that it is in the original PWB cpio format, and handle file mode bits accordingly. The default is to assume v7 format. Format iso9660 joliet Support Joliet extensions. Defaults to enabled, use !joliet to disable. rockridge Support RockRidge extensions. Defaults to enabled, use !rockridge to disable. Format lha hdrcharset The value is used as a character set name that will be used when translating file names. Format mtree checkfs Allow reading information missing from the mtree from the file system. Disabled by default. Format rar hdrcharset The value is used as a character set name that will be used when translating file names. Format tar compat-2x Libarchive 2.x incorrectly encoded Unicode filenames on some platforms. This option mimics the libarchive 2.x filename handling so that such archives can be read correctly. hdrcharset The value is used as a character set name that will be used when translating file names. mac-ext Support Mac OS metadata extension that records data in special files beginning with a period and underscore. Defaults to enabled on Mac OS, disabled on other platforms. Use !mac-ext to disable. read_concatenated_archives Ignore zeroed blocks in the archive, which occurs when multiple tar archives have been concatenated together. Without this option, only the contents of the first concatenated archive would be read.

ERRORS

Detailed error codes and textual descriptions are available from the archive_errno() and archive_error_string() functions.

SEE ALSO

tar(1), archive_read(3), archive_write_set_options(3), libarchive(3) DragonFly 6.3-DEVELOPMENT January 31, 2020 DragonFly 6.3-DEVELOPMENT

Search: Section: