DragonFly On-Line Manual Pages

Search: Section:  


ARCHIVE(8)                InterNetNews Documentation                ARCHIVE(8)

NAME

archive - Usenet article archiver

SYNOPSIS

archive [-cfr] [-a archive] [-i index] [-p pattern] [input]

DESCRIPTION

archive makes copies of files specified on its standard input. It is normally run either as a channel feed under innd or by a script before news.daily is run. archive reads the named input file, or standard input if no file is given. The input is taken as a sequence of lines; blank lines and lines starting with a number sign ("#") are ignored. All other lines should specify the token of an article to archive. Every article is retrieved from a token, and the Xref: header is used to determine the target file in the archive directory. You can limit the targets taken from the Xref: header with the -p option. Files are copied to a directory within the archive directory, patharchive in inn.conf (or some other directory given with -a). The default is to create a hierarchy that mimics a traditional news spool storage of the given articles; intermediate directories will be created as needed. For example, if the input token represents article 2211 in the newsgroup comp.sources.unix, archive will by default store the article as: comp/sources/unix/2211 in the archive area. This can be modified with the -c and -f options.

OPTIONS

-a archive If the -a flag is given, its argument specifies the root of the archive area, instead of patharchive in inn.conf. -c If the -c flag is given, directory names will be flattened as described under the -f option. Then, additionally, all posts will be concatenated into a single file, appending to that file if it already exists. The file name will be "YYYYMM", formed from the current time when archive is run. In other words, if given an article in comp.sources.unix on December 14th, 1998, the article would be appended to the file: comp.sources.unix/199812 in the archive area. Articles will be separated by a line containing only "-----------". -f If the -f flag is used, directory names will be flattened, replacing the slashes with the periods. In other words, article 2211 in comp.sources.unix will be written to: comp.sources.unix/2211 in the archive area. -i index If the -i flag is used, archive will append one line to the file index for each article that it archives. This line will contain the destination file name, the Message-ID: header, and the Subject: header of the message, separated by spaces. If either header is missing (normally not possible if the article was accepted by innd), it will be replaced by "<none>". The headers will be transformed using the same rules as are used to generate overview data (unfolded and then with tabs, CR, and LF replaced by spaces). -p pattern Limits the targets taken from the Xref: header to the groups specified in pattern. pattern is a uwildmat(3) pattern matching newsgroups that you wish to have archive handle. -r By default, archive sets its standard error to pathlog/errlog. To suppress this redirection, use the -r flag.

RETURN VALUE

If the input is exhausted, archive will exit with a zero status. If an I/O error occurs, it will try to spool its input, copying it to a file. If there was no input filename, the standard input will be copied to pathoutgoing/archive and the program will exit. If an input filename was given, a temporary file named input.bch (if input is an absolute pathname) or pathoutgoing/input.bch (if the filename does not begin with a slash) is created. Once the input is copied, archive will try to rename this temporary file to be the name of the input file, and then exit.

EXAMPLES

A typical newsfeeds(5) entry to archive most source newsgroups is as follows: source-archive!\ :!*,*sources*,!*wanted*,!*.d\ :Tc,Wn\ :<pathbin>/archive -f -i <patharchive>/INDEX Replace <pathbin> and <patharchive> with the appropriate paths.

HISTORY

Written by Rich $alz <rsalz@uunet.uu.net> for InterNetNews. Converted to POD by Russ Allbery <eagle@eyrie.org>. $Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $

SEE ALSO

inn.conf(5), newsfeeds(5). INN 2.6.0 2015-09-12 ARCHIVE(8) ARCHIVE_WRITE_FORMAT(3) DragonFly Library Functions Manual

NAME

archive_write_set_format, archive_write_set_format_7zip, archive_write_set_format_ar, archive_write_set_format_ar_bsd, archive_write_set_format_ar_svr4, archive_write_set_format_by_name, archive_write_set_format_cpio, archive_write_set_format_cpio_bin, archive_write_set_format_cpio_newc, archive_write_set_format_cpio_odc, archive_write_set_format_cpio_pwb, archive_write_set_format_filter_by_ext, archive_write_set_format_filter_by_ext_def, archive_write_set_format_gnutar, archive_write_set_format_iso9660, archive_write_set_format_mtree, archive_write_set_format_mtree_classic, archive_write_set_format_mtree_default, archive_write_set_format_pax, archive_write_set_format_pax_restricted, archive_write_set_format_raw, archive_write_set_format_shar, archive_write_set_format_shar_dump, archive_write_set_format_ustar, archive_write_set_format_v7tar, archive_write_set_format_warc, archive_write_set_format_xar, archive_write_set_format_zip - functions for creating archives

LIBRARY

Streaming Archive Library (libarchive, -larchive)

SYNOPSIS

#include <archive.h> int archive_write_set_format(struct archive *, int code); int archive_write_set_format_7zip(struct archive *); int archive_write_set_format_ar(struct archive *); int archive_write_set_format_ar_bsd(struct archive *); int archive_write_set_format_ar_svr4(struct archive *); int archive_write_set_format_by_name(struct archive *, const char *name); int archive_write_set_format_cpio(struct archive *); int archive_write_set_format_cpio_bin(struct archive *); int archive_write_set_format_cpio_newc(struct archive *); int archive_write_set_format_cpio_odc(struct archive *); int archive_write_set_format_cpio_pwb(struct archive *); int archive_write_set_format_filter_by_ext(struct archive *, const char *filename); int archive_write_set_format_filter_by_ext_def(struct archive *, const char *filename, const char *def_ext); int archive_write_set_format_gnutar(struct archive *); int archive_write_set_format_iso9660(struct archive *); int archive_write_set_format_mtree(struct archive *); int archive_write_set_format_pax(struct archive *); int archive_write_set_format_pax_restricted(struct archive *); int archive_write_set_format_raw(struct archive *); int archive_write_set_format_shar(struct archive *); int archive_write_set_format_shar_dump(struct archive *); int archive_write_set_format_ustar(struct archive *); int archive_write_set_format_v7tar(struct archive *); int archive_write_set_format_warc(struct archive *); int archive_write_set_format_xar(struct archive *); int archive_write_set_format_zip(struct archive *);

DESCRIPTION

These functions set the format that will be used for the archive. The library can write a variety of common archive formats. archive_write_set_format() Sets the format based on the format code (see archive.h for the full list of format codes). In particular, this can be used in conjunction with archive_format() to create a new archive with the same format as an existing archive. archive_write_set_format_by_name() Sets the corresponding format based on the common name. archive_write_set_format_filter_by_ext() archive_write_set_format_filter_by_ext_def() Sets both filters and format based on the output filename. Supported extensions: .7z, .zip, .jar, .cpio, .iso, .a, .ar, .tar, .tgz, .tar.gz, .tar.bz2, .tar.xz archive_write_set_format_7zip() archive_write_set_format_ar_bsd() archive_write_set_format_ar_svr4() archive_write_set_format_cpio() archive_write_set_format_cpio_bin() archive_write_set_format_cpio_newc() archive_write_set_format_cpio_odc() archive_write_set_format_cpio_pwb() archive_write_set_format_gnutar() archive_write_set_format_iso9660() archive_write_set_format_mtree() archive_write_set_format_mtree_classic() archive_write_set_format_pax() archive_write_set_format_pax_restricted() archive_write_set_format_raw() archive_write_set_format_shar() archive_write_set_format_shar_dump() archive_write_set_format_ustar() archive_write_set_format_v7tar() archive_write_set_format_warc() archive_write_set_format_xar() archive_write_set_format_zip() Set the format as specified. More details on the formats supported by libarchive can be found in the libarchive-formats(5) manual page.

RETURN VALUES

These functions return ARCHIVE_OK on success, or ARCHIVE_FATAL.

ERRORS

Detailed error codes and textual descriptions are available from the archive_errno() and archive_error_string() functions.

SEE ALSO

tar(1), archive_write(3), archive_write_set_options(3), libarchive(3), cpio(5), libarchive-formats(5), mtree(5), tar(5) DragonFly 6.3-DEVELOPMENT February 14, 2013 DragonFly 6.3-DEVELOPMENT

Search: Section: