DragonFly On-Line Manual Pages
COREPOWER(4) DragonFly Kernel Interfaces Manual COREPOWER(4)
corepower -- device driver for Intel Core on-die power usage estimation
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The corepower driver provides support for Intel's on-die power usage
estimation, that is provided in Sandy Bridge and newer Core and Xeon
CPUs, and in Atom CPUs of the Silvermont and newer architectures. The
values are exposed through the HW_SENSORS sysctl(3) tree. For example:
% sysctl hw.sensors
hw.sensors.cpu_node0.power0: 0.84 W (node0 Package Power)
hw.sensors.cpu_node0.power1: 0.73 W (node0 DRAM Power)
hw.sensors.cpu_node0.power2: 0.02 W (node0 Cores Power)
hw.sensors.cpu_node0.power3: 0.00 W (node0 Graphics Power)
Both the ``Cores Power'' and the ``Graphics Power'' values are included
in the ``Package Power'' value, which estimates the total power usage of
the CPU package.
systat(1), sysctl(3), devctl(4), devd(8), sensorsd(8), sysctl(8)
The corepower driver first appeared in DragonFly 4.3.
The corepower driver was written by Imre Vadasz <firstname.lastname@example.org>.
For some Xeon and Core-i CPUs this driver might incorrectly assume that
the MSR_PP1_ENERGY_STATUS MSR for measuring power usage of the integrated
GPU is available.
DragonFly 4.3 August 12, 2015 DragonFly 4.3