DragonFly On-Line Manual Pages
FSTAB(5) DragonFly File Formats Manual FSTAB(5)
NAME
fstab - static information about the file systems
SYNOPSIS
#include <fstab.h>
DESCRIPTION
The file fstab contains descriptive information about the various file
systems. fstab is only read by programs, and not written; it is the duty
of the system administrator to properly create and maintain this file.
Each file system is described on a separate line; fields on each line are
separated by tabs or spaces. The order of records in fstab is important
because fsck(8), mount(8), and umount(8) sequentially iterate through
fstab doing their thing.
The first field, (fs_spec), describes the special file or remote file
system to be mounted. This may be a /dev/<path>, a label from a
devtab(5) (typically /etc/devtab), or a <host>:<path> for NFS. Note that
devtab(5) labels maybe augmented with a .suffix trailer. For example
mydisk.s1a. Also note /dev based paths can mount serial numbers similar
to devtab(5) labels by using the path /dev/serno/SERIALNO[.suffix].
The second field, (fs_file), describes the mount point for the file
system. For swap partitions, this field should be specified as "none".
The third field, (fs_vfstype), describes the type of the file system.
The system can support various file system types. Only the root, /usr,
and /tmp file systems need be statically compiled into the kernel;
everything else will be automatically loaded at mount time. (Exception:
the UFS family - FFS, MFS, and LFS cannot currently be demand-loaded.)
Some people still prefer to statically compile other file systems as
well.
The most common file system types are:
HAMMER a local HAMMER(5) file system
HAMMER2 a local HAMMER2 file system
ufs a local ffs(5) UNIX file system
mfs a local memory-based UNIX file system
nfs a Sun Microsystems compatible "Network File System"
swap a disk partition to be used for swapping
msdos a local msdos(5) DOS compatible file system
cd9660 a local CD-ROM file system (as per ISO 9660)
procfs a file system for accessing process data
The fourth field, (fs_mntops), describes the mount options associated
with the file system. It is formatted as a comma separated list of
options. It contains at least the type of mount (see fs_type below) plus
any additional options appropriate to the file system type. See the
options flag (-o) in the mount(8) page and the file system specific page,
such as mount_nfs(8), for additional options that may be specified.
If the options ``userquota'' and/or ``groupquota'' are specified, the
file system is automatically processed by the quotacheck(8) command, and
user and/or group disk quotas are enabled with quotaon(8). By default,
file system quotas are maintained in files named quota.user and
quota.group which are located at the root of the associated file system.
These defaults may be overridden by putting an equal sign and an
alternative absolute pathname following the quota option. Thus, if the
user quota file for /tmp is stored in /var/quotas/tmp.user, this location
can be specified as:
userquota=/var/quotas/tmp.user
If the option ``noauto'' is specified, the file system will not be
automatically mounted at system startup. This is recommended for all
remote file systems other than NFS, since only NFS mounts are delayed
until after network initialization by the rc(8) startup scripts.
Swap partitions may specify the option ``crypt'' to automatically encrypt
the swap partition with a random key. Note that you will not be able to
recover any kernel core dumps if you use this option.
The type of the mount is extracted from the fs_mntops field and stored
separately in the fs_type field (it is not deleted from the fs_mntops
field). If fs_type is ``rw'' or ``ro'' then the file system whose name
is given in the fs_file field is normally mounted read-write or read-only
on the specified special file. If fs_type is ``sw'' then the special
file is made available as a piece of swap space by the swapon(8) command
at the end of the system reboot procedure. The fields other than fs_spec
and fs_type are unused. If fs_type is specified as ``xx'' the entry is
ignored. This is useful to show disk partitions which are currently
unused.
The fifth field, (fs_freq), is used for these file systems by the dump(8)
command to determine which file systems need to be dumped. If the fifth
field is not present, a value of zero is returned and dump will assume
that the file system does not need to be dumped.
The sixth field, (fs_passno), is used by the fsck(8) program to determine
the order in which file system checks are done at reboot time. The root
file system should be specified with a fs_passno of 1, and other file
systems should have a fs_passno of 2. File systems within a drive will
be checked sequentially, but file systems on different drives will be
checked at the same time to utilize parallelism available in the
hardware. If the sixth field is not present or is zero, a value of zero
is returned and fsck(8) will assume that the file system does not need to
be checked.
#define FSTAB_RW "rw" /* read/write device */
#define FSTAB_RQ "rq" /* read/write with quotas */
#define FSTAB_RO "ro" /* read-only device */
#define FSTAB_SW "sw" /* swap device */
#define FSTAB_XX "xx" /* ignore totally */
struct fstab {
char *fs_spec; /* block special device name */
char *fs_file; /* file system path prefix */
char *fs_vfstype; /* File system type, ufs, nfs */
char *fs_mntops; /* Mount options ala -o */
char *fs_type; /* FSTAB_* from fs_mntops */
int fs_freq; /* dump frequency, in days */
int fs_passno; /* pass number on parallel fsck */
};
The proper way to read records from fstab is to use the routines
getfsent(3), getfsspec(3), getfstype(3), and getfsfile(3).
FILES
/etc/fstab The file fstab resides in /etc.
SEE ALSO
getfsent(3), getvfsbyname(3), HAMMER(5), dump(8), fsck(8), mount(8),
quotacheck(8), quotaon(8), swapon(8), umount(8)
HISTORY
The fstab file format appeared in 4.0BSD.
DragonFly 5.9-DEVELOPMENT March 20, 2020 DragonFly 5.9-DEVELOPMENT