DragonFly On-Line Manual Pages
MOUNT(8) DragonFly System Manager's Manual MOUNT(8)
NAME
mount - mount file systems
SYNOPSIS
mount [-adfpruvw] [-F fstab] [-o options] [-t type]
mount [-dfpruvw] {special | node}
mount [-dfpruvw] [-o options] [-t type] special node
DESCRIPTION
The mount utility calls the mount(2) system call to prepare and graft a
special device or the remote node (rhost:path) or a HAMMER2 label
(@label) on to the file system tree at the point node. If either special
or node are not provided, the appropriate information is taken from the
fstab(5) file.
The system maintains a list of currently mounted file systems. If no
arguments are given to mount, this list is printed.
The options are as follows:
-a All the filesystems described in fstab(5) are mounted.
Exceptions are those marked as "noauto", excluded by the -t flag
(see below), or if they are already mounted (except the root
filesystem which is always remounted to preserve traditional
single user mode behavior).
-d Causes everything to be done except for the actual system call.
This option is useful in conjunction with the -v flag to
determine what the mount command is trying to do.
-F fstab
Specify the fstab file to use.
-f Forces the revocation of write access when trying to downgrade a
filesystem mount status from read-write to read-only. Also
forces the R/W mount of an unclean filesystem (dangerous; use
with caution).
-o Options are specified with a -o flag followed by a comma
separated string of options. If a "no" prefix is added or
removed from an option name, then meaning is negated. In case of
conflicting options being specified, the rightmost option takes
effect. The following options are available:
async All I/O to the file system should be done asynchronously.
This is a dangerous flag to set, and should not be used
unless you are prepared to recreate the file system
should your system crash.
automounted
This flag indicates that the file system was mounted by
automountd(8). Automounted file systems are
automatically unmounted by autounmountd(8).
current
When used with the -u flag, this is the same as
specifying the options currently in effect for the
mounted filesystem.
force The same as -f; forces the revocation of write access
when trying to downgrade a filesystem mount status from
read-write to read-only. Also forces the R/W mount of an
unclean filesystem (dangerous; use with caution).
fstab When used with the -u flag, this is the same as
specifying all the options listed in the fstab(5) file
for the filesystem.
noasync
Metadata I/O should be done synchronously, while data I/O
should be done asynchronously. This is the default.
noatime
Do not update the file access time when reading from a
file. This option is useful on filesystems where there
are large numbers of files and performance is more
critical than updating the file access time (which is
rarely ever important). This option is currently only
supported on local filesystems.
noauto This filesystem should be skipped when mount is run with
the -a flag.
noclusterr
Disable read clustering.
noclusterw
Disable write clustering.
nodev Do not interpret character or block special devices on
the file system. This option is useful for a server that
has file systems containing special devices for
architectures other than its own. This option is set
automatically when the user does not have super-user
privileges.
noexec Do not allow execution of any binaries on the mounted
file system. This option is useful for a server that has
file systems containing binaries for architectures other
than its own.
nosuid Do not allow set-user-identifier or set-group-identifier
bits to take effect. Note: this option is worthless if a
publicly available suid or sgid wrapper like suidperl(1)
is installed on your system. It is set automatically
when the user does not have super-user privileges.
nosymfollow
Do not follow symlinks on the mounted file system.
rdonly, ro, norw
The same as -r; mount the file system read-only (even the
super-user may not write it).
sync All I/O to the file system should be done synchronously.
trim If the device supports TRIM (kern.cam.da.X.trim_enabled
exists) and is set, the file system will perform online
trim for corresponding block deletions. Currently, only
UFS(5) supports this feature.
suiddir
A directory on the mounted filesystem will respond to the
SUID bit being set, by setting the owner of any new files
to be the same as the owner of the directory. New
directories will inherit the bit from their parents.
Execute bits are removed from the file, and it will not
be given to root.
This feature is designed for use on fileservers serving
PC users via ftp or SAMBA. It provides security holes
for shell users and as such should not be used on shell
machines, especially on home directories. This option
requires the SUIDDIR option in the kernel to work. Only
UFS(5) filesystems support this option. See chmod(2) for
more information.
update The same as -u; indicate that the status of an already
mounted file system should be changed.
ignore Will be ignored by df(1).
Any additional options specific to a filesystem type that is not
one of the internally known types (see the -t option) may be
passed as a comma separated list; these options are distinguished
by a leading "-" (dash). Options that take a value are specified
using the syntax -option=value. For example, the mount command:
mount -t mfs -o nosuid,-N,-s=4000 /dev/da0s0b /tmp
causes mount to execute the equivalent of:
/sbin/mount_mfs -o nosuid -N -s 4000 /dev/da0s0b /tmp
Additional options specific to filesystem types which are not
internally known (see the description of the -t option below) may
be described in the manual pages for the associated
/sbin/mount_XXX utilities.
-p Print mount information in fstab(5) format. If fstab is missing
or if the freq and passno fields are omitted, the default values
as described in fstab(5) are used. Implies also the -v option.
-r The file system is to be mounted read-only. Mount the file
system read-only (even the super-user may not write it). The
same as the rdonly argument to the -o option.
-t type
The argument following the -t is used to indicate the file system
type. The type ufs is the default. The -t option can be used to
indicate that the actions should only be taken on filesystems of
the specified type. More than one type may be specified in a
comma separated list. The list of filesystem types can be
prefixed with "no" to specify the filesystem types for which
action should not be taken. For example, the mount command:
mount -a -t nonfs,mfs
mounts all filesystems except those of type NFS and MFS.
If the type is not the internally known type, ufs, mount will
attempt to execute a program in /sbin/mount_XXX where XXX is
replaced by the type name. For example, nfs filesystems are
mounted by the program /sbin/mount_nfs.
Most filesystems will be dynamically loaded by their mount
programs if not already present in the kernel, using the
vfsload(3) subroutine. Because this mechanism requires writable
temporary space, the filesystem type containing /tmp must be
compiled into the kernel, and the filesystems containing /tmp and
/usr/bin/ld must be listed in /etc/fstab before any filesystems
which might be dynamically loaded.
-u The -u flag indicates that the status of an already mounted file
system should be changed. Any of the options discussed above
(the -o option) may be changed; also a file system can be changed
from read-only to read-write or vice versa. An attempt to change
from read-write to read-only will fail if any files on the
filesystem are currently open for writing unless the -f flag is
also specified. The set of options is determined by applying the
options specified in the argument to -o and finally applying the
-r or -w option.
-v Verbose mode.
-w The file system object is to be read and write.
ENVIRONMENT
PATH_FSTAB If the environment variable PATH_FSTAB is set all operations
are performed against the specified file.
FILES
/etc/fstab file system table
DIAGNOSTICS
Various, most of them are self-explanatory.
XXXXX filesystem is not available
The kernel does not support the respective filesystem type. Note that
support for a particular filesystem might be provided either on a static
(kernel compile-time), or dynamic basis (loaded as a kernel module by
kldload(8)). Normally, mount or its subprocesses attempt to dynamically
load a filesystem module if it has not been configured statically, using
vfsload(3). In this case, the above error message can also mean that you
did not have permission to load the module.
SEE ALSO
df(1), lsvfs(1), mount(2), vfsload(3), devtab(5), fstab(5), UFS(5),
automount(8), automountd(8), autounmountd(8), kldload(8),
mount_cd9660(8), mount_devfs(8), mount_ext2fs(8), mount_hammer(8),
mount_hammer2(8), mount_hpfs(8), mount_mfs(8), mount_msdos(8),
mount_nfs(8), mount_ntfs(8), mount_null(8), mount_procfs(8),
mount_smbfs(8), mount_std(8), mount_tmpfs(8), mount_udf(8), sysctl(8),
umount(8)
HISTORY
A mount utility appeared in Version 1 AT&T UNIX.
CAVEATS
After a successful mount, the permissions on the original mount point
determine if .. is accessible from the mounted file system. The minimum
permissions for the mount point for traversal across the mount point in
both directions to be possible for all users is 0111 (execute for all).
BUGS
It is possible for a corrupted file system to cause a crash.
DragonFly 6.1-DEVELOPMENT May 15, 2016 DragonFly 6.1-DEVELOPMENT