DragonFly On-Line Manual Pages
VPUT(9) DragonFly Kernel Developer's Manual VPUT(9)
NAME
vput -- Decrement the primary reference count for a vnode and unlock it
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
void
vput(struct vnode *vp);
DESCRIPTION
Decrement the vnode's primary reference count (via the v_sysref field)
and unlock the vnode.
vp The vnode in question.
This operation is functionally equivalent to calling vn_unlock(9) fol-
lowed by vrele(9). Releasing the last primary reference on a vnode will
cause it to be deactivated and either moved to the free list or cached.
Vnodes with namecache and/or VM objects are typically marked as being
cached unless the system needs the memory for other purposes.
SEE ALSO
vdrop(9), vget(9), vhold(9), vnode(9), vn_lock(9), vn_unlock(9), vref(9),
vrele(9)
AUTHORS
This manual page was written by Doug Rabson.
DragonFly 3.5 May 5, 2007 DragonFly 3.5