DragonFly On-Line Manual Pages
VRELE(9) DragonFly Kernel Developer's Manual VRELE(9)
NAME
vrele -- Release a previously obtained primary reference for a vnode
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
void
vrele(struct vnode *vp);
DESCRIPTION
The caller is holding a primary reference to the vnode and wishes to
release it.
vp The vnode being released.
Any code in the system which obtains a primary reference to a vnode via
vref(9) typically releases that reference with vrele() when it is fin-
ished with the vnode. Upon release of the last primary reference, the
vnode will be deactivated and either moved to the free list for later re-
use or marked as being cache. The vnode can be reactivated at any time
prior to the system reusing it.
SEE ALSO
vdrop(9), vget(9), vhold(9), vnode(9), vn_lock(9), vn_unlock(9), vput(9),
vref(9)
AUTHORS
This manual page was written by Doug Rabson.
DragonFly 3.5 May 5, 2007 DragonFly 3.5