DragonFly On-Line Manual Pages
ACPI(4) DragonFly Kernel Interfaces Manual ACPI(4)
acpi - Advanced Configuration and Power Management support
The acpi driver provides support for the Intel/Microsoft/Compaq/Toshiba
ACPI standard. This support includes platform hardware discovery
(superseding the PnP and PCI BIOS), as well as power management
(superseding APM) and other features. ACPI core support is provided by
the ACPICA reference implementation from Intel.
The acpi driver is usually compiled into the kernel, and it is
automatically loaded by the loader(8) if it is not in the kernel
configuration file. The loader menu provides a menu item to boot without
ACPI. See also DISABLING ACPI below.
The acpi driver is intended to provide power management without user
intervention. If the default settings are not optimal, the following
sysctls can be used to modify or monitor acpi behavior.
Enable dumping Debug objects without options ACPI_DEBUG. Default
is 0, ignore Debug objects.
AC line state (1 means online, 0 means on battery power).
Debugging information listing the percent of total usage for each
sleep state. The values are reset when hw.acpi.cpu.cx_lowest is
Lowest Cx state to use for idling the CPU. A scheduling
algorithm will select states between C1 and this setting as
system load dictates. To enable ACPI CPU idling control,
machdep.cpu_idle_hlt must be set to 2 (the default value).
List of supported CPU idle states and their transition latency in
microseconds. Each state has a type (e.g., C2). C1 is
equivalent to the ia32 HLT instruction, C2 provides a deeper
sleep with the same semantics, and C3 provides the deepest sleep
but additionally requires bus mastering to be disabled. States
greater than C3 provide even more power savings with the same
semantics as the C3 state. Deeper sleeps provide more power
savings but increased transition latency when an interrupt
Disable ACPI during the reboot process. Most systems reboot fine
with ACPI still enabled, but some require exiting to legacy mode
first. Default is 0, leave ACPI enabled.
Use the ACPI Reset Register capability to reboot the system.
Default is 0, use legacy reboot support. Some newer systems
require use of this register, while some only work with legacy
Suspend state (S1-S5) to enter when the lid switch (i.e., a
notebook screen) is closed. Default is "NONE" (do nothing).
Suspend state (S1-S5) to enter when the power button is pressed.
Default is S5 (power-off nicely).
Reset the video adapter from real mode during the resume path.
Some systems need this help, others have display problems if it
is enabled. Default is 0 (disabled).
Indicate whether the system supports S4BIOS. This means that the
BIOS can handle all the functions of suspending the system to
disk. Otherwise, the OS is responsible for suspending to disk
(S4OS). Most current systems do not support S4BIOS.
Suspend state (S1-S5) to enter when the sleep button is pressed.
This is usually a special function button on the keyboard.
Default is S3 (suspend-to-RAM).
Wait this number of seconds between preparing the system to
suspend and actually entering the suspend state. Default is 1
Suspend states (S1-S5) supported by the BIOS.
S1 Quick suspend to RAM. The CPU enters a lower power
state, but most peripherals are left running.
S2 Lower power state than S1, but with the same basic
characteristics. Not supported by many systems.
S3 Suspend to RAM. Most devices are powered off, and the
system stops running except for memory refresh.
S4 Suspend to disk. All devices are powered off, and the
system stops running. When resuming, the system starts
as if from a cold power on. Not yet supported by FreeBSD
unless S4BIOS is available.
S5 System shuts down cleanly and powers off.
Enable verbose printing from the various ACPI subsystems.
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in /boot/loader.conf. Many of these tunables also have a matching
sysctl(8) entry for access after boot.
Enables loading of a custom ACPI DSDT.
Name of the DSDT table to load, if loading is enabled. It is
relative to /boot/kernel.
If set, the acpicall(8) utility can be used to directly call ACPI
methods for debugging and tweaking purposes.
Selectively disables portions of ACPI that are enabled by
default, for debugging purposes.
Selectively enables portions of ACPI that are disabled by
default, for debugging purposes.
Favor 32-bit FACS table addresses over the 64-bit addresses.
Favor 32-bit FADT register addresses over the 64-bit addresses.
Ignore the XSDT, forcing the use of the RSDT.
Enable less strict ACPI implementations. Default is 1, ignore
common BIOS mistakes.
Specify the number of task threads that are started on boot.
Limiting this to 1 may help work around various BIOSes that
cannot handle parallel requests. The default value is 3.
Override any automatic quirks completely.
Beep the PC speaker on resume. This can help diagnose
suspend/resume problems. Default is 0 (disabled).
Set this to 1 to disable all of ACPI. If ACPI has been disabled
on your system due to a blacklist entry for your BIOS, you can
set this to 0 to re-enable ACPI for testing.
Delay in milliseconds to wait for the EC to respond. Try
increasing this number if you get the error
Override the assumed memory starting address for PCI host
Install or remove OS interface(s) to control the return value of
the `_OSI' query method. When an OS interface is specified in
hw.acpi.install_interface, the _OSI query for the interface
returns it is supported. Conversely, when an OS interface is
specified in hw.acpi.remove_interface, the _OSI query returns it
is not supported. Multiple interfaces can be specified in a
comma-separated list and any leading white spaces will be
ignored. For example, "FreeBSD, Linux" is a valid list of two
interfaces "FreeBSD" and "Linux".
Enables calling the VESA reset BIOS vector on the resume path.
This can fix some graphics cards that have problems such as LCD
white-out after resume. Default is 0 (disabled).
Auto-serialization of control methods to proactively prevent
problems with ill-behaved reentrant control methods that create
named ACPI objects. Default is 1 (enabled).
Turn on verbose debugging information about what ACPI is doing.
Override the interrupt to use for this link and index. This
capability should be used carefully, and only if a device is not
working with acpi enabled. "%s" is the name of the link (e.g.,
LNKA). "%d" is the resource index when the link supports
multiple IRQs. Most PCI links only have one IRQ resource, so the
below form should be used.
Override the interrupt to use. This capability should be used
carefully, and only if a device is not working with acpi enabled.
"%s" is the name of the link (e.g., LNKA).
Since ACPI support on different platforms varies greatly, there are many
debugging and tuning options available.
For machines known not to work with acpi enabled, there is a BIOS
blacklist. Currently, the blacklist only controls whether acpi should be
disabled or not. In the future, it will have more granularity to control
features (the infrastructure for that is already there).
To enable acpi (for debugging purposes, etc.) on machines that are on the
blacklist, set the kernel environment variable hint.acpi.0.disabled to 0.
Before trying this, consider updating your BIOS to a more recent version
that may be compatible with ACPI.
To disable the acpi driver completely, set the kernel environment
variable hint.acpi.0.disabled to 1.
Disabling all or part of ACPI may result in a non-functional system.
The acpi driver comprises a set of drivers, which may be selectively
disabled in case of problems. To disable a sub-driver, list it in the
kernel environment variable debug.acpi.disabled. Multiple entries can be
listed, separated by a space.
ACPI sub-devices and features that can be disabled:
all Disable all ACPI features and devices.
acad (device) Supports AC adapter.
bus (feature) Probes and attaches subdevices. Disabling
will avoid scanning the ACPI namespace entirely.
children (feature) Attaches standard ACPI sub-drivers and devices
enumerated in the ACPI namespace. Disabling this has a
similar effect to disabling "bus", except that the ACPI
namespace will still be scanned.
button (device) Supports ACPI button devices (typically power
and sleep buttons).
cmbat (device) Control-method batteries device.
cpu (device) Supports CPU power-saving and speed-setting
cpu_cst (device) Supports CPU power-saving. Disabling "cpu"
will also disable this device.
cpu_pst (device) Supports CPU speed-setting. Disabling "cpu"
will also disable this device.
dock (device) Docking station device.
ec (device) Supports the ACPI Embedded Controller
interface, used to communicate with embedded platform
hpet (feature) Supports the High Precision Event Timer.
isa (device) Supports an ISA bus bridge defined in the ACPI
namespace, typically as a child of a PCI bus.
lid (device) Supports an ACPI laptop lid switch, which
typically puts a system to sleep.
quirks (feature) Do not honor quirks. Quirks automatically
disable ACPI functionality based on the XSDT table's OEM
vendor name and revision date.
pci (device) Supports Host to PCI bridges.
pci_link (feature) Performs PCI interrupt routing.
sysresource (device) Pseudo-devices containing resources which ACPI
thermal (device) Supports system cooling and heat management.
timer (device) Implements a timecounter using the ACPI fixed-
video (device) Supports acpi_video(4) which may conflict with
It is also possible to avoid portions of the ACPI namespace which may be
causing problems, by listing the full path of the root of the region to
be avoided in the kernel environment variable debug.acpi.avoid. The
object and all of its children will be ignored during the bus/children
scan of the namespace. The ACPICA code will still know about the avoided
To enable debugging output, acpi must be compiled with options
ACPI_DEBUG. Debugging output is separated between layers and levels,
where a layer is a component of the ACPI subsystem, and a level is a
particular kind of debugging output.
Both layers and levels are specified as a whitespace-separated list of
tokens, with layers listed in debug.acpi.layer and levels in
The first set of layers is for ACPICA components, and the second is for
DragonFly drivers. The ACPICA layer descriptions include the prefix for
the files they refer to. The supported layers are:
ACPI_UTILITIES Utility ("ut") functions
ACPI_HARDWARE Hardware access ("hw")
ACPI_EVENTS Event and GPE ("ev")
ACPI_TABLES Table access ("tb")
ACPI_NAMESPACE Namespace evaluation ("ns")
ACPI_PARSER AML parser ("ps")
ACPI_DISPATCHER Internal representation of interpreter state
ACPI_EXECUTER Execute AML methods ("ex")
ACPI_RESOURCES Resource parsing ("rs")
ACPI_CA_DEBUGGER Debugger implementation ("db", "dm")
ACPI_OS_SERVICES Usermode support routines ("os")
ACPI_CA_DISASSEMBLER Disassembler implementation (unused)
ACPI_ALL_COMPONENTS All the above ACPICA components
ACPI_AC_ADAPTER AC adapter driver
ACPI_BATTERY Control-method battery driver
ACPI_BUS ACPI, ISA, and PCI bus drivers
ACPI_BUTTON Power and sleep button driver
ACPI_EC Embedded controller driver
ACPI_FAN Fan driver
ACPI_OEM Platform-specific driver for hotkeys, LED, etc.
ACPI_POWER Power resource driver
ACPI_PROCESSOR CPU driver
ACPI_THERMAL Thermal zone driver
ACPI_TIMER Timer driver
ACPI_ALL_DRIVERS All the above DragonFly ACPI drivers
The supported levels are:
ACPI_LV_INIT Initialization progress
ACPI_LV_DEBUG_OBJECT Stores to objects
ACPI_LV_INFO General information and progress
ACPI_LV_REPAIR Repair a common problem with predefined
ACPI_LV_ALL_EXCEPTIONS All the previous levels
ACPI_LV_VERBOSITY1 All the previous levels
ACPI_LV_VERBOSITY2 All the previous levels
ACPI_LV_ALL Alias for "ACPI_LV_VERBOSITY2"
ACPI_LV_VERBOSITY3 All the previous levels
ACPI_LV_VERBOSE All levels after "ACPI_LV_VERBOSITY3"
ACPI_LV_INIT_NAMES Needs to be specified separately
ACPI_LV_LOAD Needs to be specified separately
Selection of the appropriate layer and level values is important to avoid
massive amounts of debugging output. For example, the following
configuration is a good way to gather initial information. It enables
debug output for both ACPICA and the acpi driver, printing basic
information about errors, warnings, and progress.
Debugging output by the ACPICA subsystem is prefixed with the module name
in lowercase, followed by a source line number. Output from the
DragonFly-local code follows the same format, but the module name is
OVERRIDING YOUR BIOS BYTECODE
ACPI interprets bytecode named AML (ACPI Machine Language) provided by
the BIOS vendor as a memory image at boot time. Sometimes, the AML code
contains a bug that does not appear when parsed by the Microsoft
implementation. DragonFly provides a way to override it with your own
AML code to work around or debug such problems. Note that all AML in
your DSDT and any SSDT tables is overridden.
In order to load your AML code, copy it to /boot/kernel/acpi_dsdt.aml and
add the following line to /boot/loader.conf.
In order to prepare your AML code, you will need the acpidump(8) and
iasl(8) utilities and some ACPI knowledge.
kenv(1), acpi_asus(4), acpi_dock(4), acpi_fujitsu(4), acpi_hp(4),
acpi_panasonic(4), acpi_sony(4), acpi_thermal(4), acpi_thinkpad(4),
acpi_toshiba(4), acpi_video(4), aibs(4), loader.conf(5), acpibin(8),
acpicall(8), acpiconf(8), acpidump(8), acpiexec(8), acpixtract(8),
Hewlett-Packard Corporation, Intel Corporation, Microsoft Corporation,
Phoenix Technologies Ltd., and Toshiba Corporation, Advanced
Configuration and Power Interface Specification,
http://acpi.info/spec.htm, November 13, 2013.
The ACPICA subsystem is developed and maintained by Intel Architecture
The following people made notable contributions to the ACPI subsystem in
DragonFly: Michael Smith, Takanori Watanabe <takawata@jp.FreeBSD.org>,
Mitsuru IWASAKI <iwasaki@jp.FreeBSD.org>, Munehiro Matsuda, Nate Lawson,
the ACPI-jp mailing list at <acpi-jp@jp.FreeBSD.org>, and many other
This manual page was written by Michael Smith <msmith@FreeBSD.org>.
Many BIOS versions have serious bugs that may cause system instability,
break suspend/resume, or prevent devices from operating properly due to
IRQ routing problems. Upgrade your BIOS to the latest version available
from the vendor before deciding it is a problem with acpi.
DragonFly 5.9-DEVELOPMENT May 29, 2020 DragonFly 5.9-DEVELOPMENT