DragonFly On-Line Manual Pages
ACPICALL(8) DragonFly System Manager's Manual ACPICALL(8)
acpicall - call ACPI methods
acpicall [-v] [-b hexstring] [-d file] [-i number] [-o i | s | b | o]
[-s string] [-U uuid] path
The acpicall utility calls the ACPI method path with the arguments
specified by any -b, -i, -o, -s, and -U options. The path argument must
be a full ACPI namespace path such as \_SB.PCI0.PEGR.GFX0._DSM.
Note that in order to be able to use the acpicall utility, the
debug.acpi.allow_method_calls loader tunable must be specified in
The following options are supported:
Pass hexstring as a buffer argument.
Specify the path of the ACPI control device. The default is
Pass number as an integer argument.
-o i | s | b | o
Choose the format to print the result in: (i)nteger, (s)tring,
(b)uffer, or (o)bject.
Pass string as a string argument.
Pass uuid as a buffer argument.
-v Increase verbosity.
Note that many ACPI methods are specific to the BIOS and machine in
question, so it is impossible to present any generic examples that will
work everywhere. Some familiarity with ASL and the DSDT code of the
specific machine to be tweaked is highly recommended.
The following calls were successfully used to turn off the discrete
NVIDIA GPU on the Optimus based Asus K53SV laptop:
acpicall -U a486d8f8-0bda-471b-a72b-6042a6b5bee0 \
-i 256 -i 26 -b 01000003 "\_SB.PCI0.PEGR.GFX0._DSM"
acpi(4), acpibin(8), acpiconf(8), acpidump(8), acpiexec(8), acpihelp(8),
acpicall is based on the acpi_call utility by Maxim Ignatenko
<email@example.com>. This manual page was written by
DragonFly 5.9-DEVELOPMENT May 29, 2020 DragonFly 5.9-DEVELOPMENT