DragonFly On-Line Manual Pages
ARCHIVE(8) InterNetNews Documentation ARCHIVE(8)
archive - Usenet article archiver
archive [-cfr] [-a archive] [-i index] [-p pattern] [input]
archive makes copies of files specified on its standard input. It is
normally run either as a channel feed under innd or by a script before
news.daily is run.
archive reads the named input file, or standard input if no file is
given. The input is taken as a sequence of lines; blank lines and
lines starting with a number sign ("#") are ignored. All other lines
should specify the token of an article to archive. Every article is
retrieved from a token, and the Xref: header is used to determine the
target file in the archive directory. You can limit the targets taken
from the Xref: header with the -p option.
Files are copied to a directory within the archive directory,
patharchive in inn.conf (or some other directory given with -a). The
default is to create a hierarchy that mimics a traditional news spool
storage of the given articles; intermediate directories will be created
as needed. For example, if the input token represents article 2211 in
the newsgroup comp.sources.unix, archive will by default store the
in the archive area. This can be modified with the -c and -f options.
If the -a flag is given, its argument specifies the root of the
archive area, instead of patharchive in inn.conf.
-c If the -c flag is given, directory names will be flattened as
described under the -f option. Then, additionally, all posts will
be concatenated into a single file, appending to that file if it
already exists. The file name will be "YYYYMM", formed from the
current time when archive is run. In other words, if given an
article in comp.sources.unix on December 14th, 1998, the article
would be appended to the file:
in the archive area.
Articles will be separated by a line containing only "-----------".
-f If the -f flag is used, directory names will be flattened,
replacing the slashes with the periods. In other words, article
2211 in comp.sources.unix will be written to:
in the archive area.
If the -i flag is used, archive will append one line to the file
index for each article that it archives. This line will contain
the destination file name, the Message-ID: header, and the Subject:
header of the message, separated by spaces. If either header is
missing (normally not possible if the article was accepted by
innd), it will be replaced by "<none>". The headers will be
transformed using the same rules as are used to generate overview
data (unfolded and then with tabs, CR, and LF replaced by spaces).
Limits the targets taken from the Xref: header to the groups
specified in pattern. pattern is a uwildmat(3) pattern matching
newsgroups that you wish to have archive handle.
-r By default, archive sets its standard error to pathlog/errlog. To
suppress this redirection, use the -r flag.
If the input is exhausted, archive will exit with a zero status. If an
I/O error occurs, it will try to spool its input, copying it to a file.
If there was no input filename, the standard input will be copied to
pathoutgoing/archive and the program will exit. If an input filename
was given, a temporary file named input.bch (if input is an absolute
pathname) or pathoutgoing/input.bch (if the filename does not begin
with a slash) is created. Once the input is copied, archive will try
to rename this temporary file to be the name of the input file, and
A typical newsfeeds(5) entry to archive most source newsgroups is as
:<pathbin>/archive -f -i <patharchive>/INDEX
Replace <pathbin> and <patharchive> with the appropriate paths.
Written by Rich $alz <email@example.com> for InterNetNews. Converted
to POD by Russ Allbery <firstname.lastname@example.org>.
$Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $
INN 2.6.0 2015-09-12 ARCHIVE(8)
ARCHIVE_READ_EXTRACT(3) DragonFly Library Functions Manual
archive_read_extract_set_progress_callback - functions for reading
Streaming Archive Library (libarchive, -larchive)
archive_read_extract(struct archive *, struct archive_entry *,
archive_read_extract2(struct archive *src, struct archive_entry *,
struct archive *dest);
archive_read_extract_set_progress_callback(struct archive *,
void (*func)(void *), void *user_data);
A convenience function that wraps the corresponding
archive_write_disk(3) interfaces. The first call to
archive_read_extract() creates a restore object using
archive_write_disk_set_standard_lookup(3), then transparently
archive_write_header(3), archive_write_data(3), and
archive_write_finish_entry(3) to create the entry on disk and
copy data into it. The flags argument is passed unmodified to
This is another version of archive_read_extract() that allows you
to provide your own restore object. In particular, this allows
you to override the standard lookup functions using
archive_write_disk_set_user_lookup(3). Note that
archive_read_extract2() does not accept a flags argument; you
should use archive_write_disk_set_options() to set the restore
Sets a pointer to a user-defined callback that can be used for
updating progress displays during extraction. The progress
function will be invoked during the extraction of large regular
files. The progress function will be invoked with the pointer
provided to this call. Generally, the data pointed to should
include a reference to the archive object and the archive_entry
object so that various statistics can be retrieved for the
Most functions return zero on success, non-zero on error. The possible
return codes include: ARCHIVE_OK (the operation succeeded), ARCHIVE_WARN
(the operation succeeded but a non-critical error was encountered),
ARCHIVE_EOF (end-of-archive was encountered), ARCHIVE_RETRY (the
operation failed but can be retried), and ARCHIVE_FATAL (there was a
fatal error; the archive should be closed immediately).
Detailed error codes and textual descriptions are available from the
archive_errno() and archive_error_string() functions.
tar(1), archive_read(3), archive_read_data(3), archive_read_filter(3),
archive_read_set_options(3), archive_util(3), libarchive(3), tar(5)
DragonFly 5.9-DEVELOPMENT February 2, 2012 DragonFly 5.9-DEVELOPMENT