DragonFly On-Line Manual Pages
ARCHIVE(8) InterNetNews Documentation ARCHIVE(8)
NAME
archive - Usenet article archiver
SYNOPSIS
archive [-cfr] [-a archive] [-i index] [-p pattern] [input]
DESCRIPTION
archive makes copies of files specified on its standard input. It is
normally run either as a channel feed under innd or by a script before
news.daily is run.
archive reads the named input file, or standard input if no file is
given. The input is taken as a sequence of lines; blank lines and
lines starting with a number sign ("#") are ignored. All other lines
should specify the token of an article to archive. Every article is
retrieved from a token, and the Xref: header is used to determine the
target file in the archive directory. You can limit the targets taken
from the Xref: header with the -p option.
Files are copied to a directory within the archive directory,
patharchive in inn.conf (or some other directory given with -a). The
default is to create a hierarchy that mimics a traditional news spool
storage of the given articles; intermediate directories will be created
as needed. For example, if the input token represents article 2211 in
the newsgroup comp.sources.unix, archive will by default store the
article as:
comp/sources/unix/2211
in the archive area. This can be modified with the -c and -f options.
OPTIONS
-a archive
If the -a flag is given, its argument specifies the root of the
archive area, instead of patharchive in inn.conf.
-c If the -c flag is given, directory names will be flattened as
described under the -f option. Then, additionally, all posts will
be concatenated into a single file, appending to that file if it
already exists. The file name will be "YYYYMM", formed from the
current time when archive is run. In other words, if given an
article in comp.sources.unix on December 14th, 1998, the article
would be appended to the file:
comp.sources.unix/199812
in the archive area.
Articles will be separated by a line containing only "-----------".
-f If the -f flag is used, directory names will be flattened,
replacing the slashes with the periods. In other words, article
2211 in comp.sources.unix will be written to:
comp.sources.unix/2211
in the archive area.
-i index
If the -i flag is used, archive will append one line to the file
index for each article that it archives. This line will contain
the destination file name, the Message-ID: header, and the Subject:
header of the message, separated by spaces. If either header is
missing (normally not possible if the article was accepted by
innd), it will be replaced by "<none>". The headers will be
transformed using the same rules as are used to generate overview
data (unfolded and then with tabs, CR, and LF replaced by spaces).
-p pattern
Limits the targets taken from the Xref: header to the groups
specified in pattern. pattern is a uwildmat(3) pattern matching
newsgroups that you wish to have archive handle.
-r By default, archive sets its standard error to pathlog/errlog. To
suppress this redirection, use the -r flag.
RETURN VALUE
If the input is exhausted, archive will exit with a zero status. If an
I/O error occurs, it will try to spool its input, copying it to a file.
If there was no input filename, the standard input will be copied to
pathoutgoing/archive and the program will exit. If an input filename
was given, a temporary file named input.bch (if input is an absolute
pathname) or pathoutgoing/input.bch (if the filename does not begin
with a slash) is created. Once the input is copied, archive will try
to rename this temporary file to be the name of the input file, and
then exit.
EXAMPLES
A typical newsfeeds(5) entry to archive most source newsgroups is as
follows:
source-archive!\
:!*,*sources*,!*wanted*,!*.d\
:Tc,Wn\
:<pathbin>/archive -f -i <patharchive>/INDEX
Replace <pathbin> and <patharchive> with the appropriate paths.
HISTORY
Written by Rich $alz <rsalz@uunet.uu.net> for InterNetNews. Converted
to POD by Russ Allbery <eagle@eyrie.org>.
$Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $
SEE ALSO
inn.conf(5), newsfeeds(5).
INN 2.6.0 2015-09-12 ARCHIVE(8)
ARCHIVE_READ_FORMAT(3) DragonFly Library Functions Manual
NAME
archive_read_support_format_7zip, archive_read_support_format_all,
archive_read_support_format_ar, archive_read_support_format_by_code,
archive_read_support_format_cab, archive_read_support_format_cpio,
archive_read_support_format_empty, archive_read_support_format_iso9660,
archive_read_support_format_lha, archive_read_support_format_mtree,
archive_read_support_format_rar, archive_read_support_format_raw,
archive_read_support_format_tar, archive_read_support_format_xar,
archive_read_support_format_zip - functions for reading streaming
archives
LIBRARY
Streaming Archive Library (libarchive, -larchive)
SYNOPSIS
#include <archive.h>
int
archive_read_support_format_7zip(struct archive *);
int
archive_read_support_format_all(struct archive *);
int
archive_read_support_format_ar(struct archive *);
int
archive_read_support_format_by_code(struct archive *, int);
int
archive_read_support_format_cab(struct archive *);
int
archive_read_support_format_cpio(struct archive *);
int
archive_read_support_format_empty(struct archive *);
int
archive_read_support_format_iso9660(struct archive *);
int
archive_read_support_format_lha(struct archive *);
int
archive_read_support_format_mtree(struct archive *);
int
archive_read_support_format_rar(struct archive *);
int
archive_read_support_format_raw(struct archive *);
int
archive_read_support_format_tar(struct archive *);
int
archive_read_support_format_xar(struct archive *);
int
archive_read_support_format_zip(struct archive *);
DESCRIPTION
archive_read_support_format_7zip(), archive_read_support_format_ar(),
archive_read_support_format_cab(),
archive_read_support_format_cpio(),
archive_read_support_format_iso9660(),
archive_read_support_format_lha(),
archive_read_support_format_mtree(),
archive_read_support_format_rar(),
archive_read_support_format_raw(),
archive_read_support_format_tar(),
archive_read_support_format_xar(),
archive_read_support_format_zip()
Enables support---including auto-detection code---for the
specified archive format. For example,
archive_read_support_format_tar() enables support for a variety
of standard tar formats, old-style tar, ustar, pax interchange
format, and many common variants.
archive_read_support_format_all()
Enables support for all available formats except the "raw" format
(see below).
archive_read_support_format_by_code()
Enables a single format specified by the format code. This can
be useful when reading a single archive twice; use
archive_format() after reading the first time and pass the
resulting code to this function to selectively enable only the
necessary format support. Note: In statically-linked
executables, this will cause your program to include support for
every format. If executable size is a concern, you may wish to
avoid using this function.
archive_read_support_format_empty()
Enables support for treating empty files as empty archives.
Because empty files are valid for several different formats, it
is not possible to accurately determine a format for an empty
file based purely on contents. So empty files are treated by
libarchive as a distinct format.
archive_read_support_format_raw()
The "raw" format handler allows libarchive to be used to read
arbitrary data. It treats any data stream as an archive with a
single entry. The pathname of this entry is "data"; all other
entry fields are unset. This is not enabled by
archive_read_support_format_all() in order to avoid erroneous
handling of damaged archives.
RETURN VALUES
These functions return ARCHIVE_OK on success, or ARCHIVE_FATAL.
ERRORS
Detailed error codes and textual descriptions are available from the
archive_errno() and archive_error_string() functions.
SEE ALSO
tar(1), archive_read_data(3), archive_read_filter(3),
archive_read_set_options(3), archive_util(3), libarchive(3), tar(5)
BUGS
Many traditional archiver programs treat empty files as valid empty
archives. For example, many implementations of tar(1) allow you to
append entries to an empty file. Of course, it is impossible to
determine the format of an empty file by inspecting the contents, so this
library treats empty files as having a special "empty" format.
Using the "raw" handler together with any other handler will often work
but can produce surprising results.
DragonFly 5.9-DEVELOPMENT February 2, 2012 DragonFly 5.9-DEVELOPMENT