DragonFly On-Line Manual Pages
ARCHIVE(8) InterNetNews Documentation ARCHIVE(8)
archive - Usenet article archiver
archive [-cfr] [-a archive] [-i index] [-p pattern] [input]
archive makes copies of files specified on its standard input. It is
normally run either as a channel feed under innd or by a script before
news.daily is run.
archive reads the named input file, or standard input if no file is
given. The input is taken as a sequence of lines; blank lines and
lines starting with a number sign ("#") are ignored. All other lines
should specify the token of an article to archive. Every article is
retrieved from a token, and the Xref: header is used to determine the
target file in the archive directory. You can limit the targets taken
from the Xref: header with the -p option.
Files are copied to a directory within the archive directory,
patharchive in inn.conf (or some other directory given with -a). The
default is to create a hierarchy that mimics a traditional news spool
storage of the given articles; intermediate directories will be created
as needed. For example, if the input token represents article 2211 in
the newsgroup comp.sources.unix, archive will by default store the
in the archive area. This can be modified with the -c and -f options.
If the -a flag is given, its argument specifies the root of the
archive area, instead of patharchive in inn.conf.
-c If the -c flag is given, directory names will be flattened as
described under the -f option. Then, additionally, all posts will
be concatenated into a single file, appending to that file if it
already exists. The file name will be "YYYYMM", formed from the
current time when archive is run. In other words, if given an
article in comp.sources.unix on December 14th, 1998, the article
would be appended to the file:
in the archive area.
Articles will be separated by a line containing only "-----------".
-f If the -f flag is used, directory names will be flattened,
replacing the slashes with the periods. In other words, article
2211 in comp.sources.unix will be written to:
in the archive area.
If the -i flag is used, archive will append one line to the file
index for each article that it archives. This line will contain
the destination file name, the Message-ID: header, and the Subject:
header of the message, separated by spaces. If either header is
missing (normally not possible if the article was accepted by
innd), it will be replaced by "<none>". The headers will be
transformed using the same rules as are used to generate overview
data (unfolded and then with tabs, CR, and LF replaced by spaces).
Limits the targets taken from the Xref: header to the groups
specified in pattern. pattern is a uwildmat(3) pattern matching
newsgroups that you wish to have archive handle.
-r By default, archive sets its standard error to pathlog/errlog. To
suppress this redirection, use the -r flag.
If the input is exhausted, archive will exit with a zero status. If an
I/O error occurs, it will try to spool its input, copying it to a file.
If there was no input filename, the standard input will be copied to
pathoutgoing/archive and the program will exit. If an input filename
was given, a temporary file named input.bch (if input is an absolute
pathname) or pathoutgoing/input.bch (if the filename does not begin
with a slash) is created. Once the input is copied, archive will try
to rename this temporary file to be the name of the input file, and
A typical newsfeeds(5) entry to archive most source newsgroups is as
:<pathbin>/archive -f -i <patharchive>/INDEX
Replace <pathbin> and <patharchive> with the appropriate paths.
Written by Rich $alz <firstname.lastname@example.org> for InterNetNews. Converted
to POD by Russ Allbery <email@example.com>.
$Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $
INN 2.6.0 2015-09-12 ARCHIVE(8)
ARCHIVE_WRITE_BLOCKSIZE(3) DragonFly Library Functions Manual
archive_write_set_bytes_in_last_block - functions for creating archives
Streaming Archive Library (libarchive, -larchive)
archive_write_get_bytes_per_block(struct archive *);
archive_write_set_bytes_per_block(struct archive *, int bytes_per_block);
archive_write_get_bytes_in_last_block(struct archive *);
archive_write_set_bytes_in_last_block(struct archive *, int);
Sets the block size used for writing the archive data. Every
call to the write callback function, except possibly the last
one, will use this value for the length. The default is to use a
block size of 10240 bytes. Note that a block size of zero will
suppress internal blocking and cause writes to be sent directly
to the write callback as they occur.
Retrieve the block size to be used for writing. A value of -1
here indicates that the library should use default values. A
value of zero indicates that internal blocking is suppressed.
Sets the block size used for writing the last block. If this
value is zero, the last block will be padded to the same size as
the other blocks. Otherwise, the final block will be padded to a
multiple of this size. In particular, setting it to 1 will cause
the final block to not be padded. For compressed output, any
padding generated by this option is applied only after the
compression. The uncompressed data is always unpadded. The
default is to pad the last block to the full block size (note
that archive_write_open_filename() will set this based on the
file type). Unlike the other "set" functions, this function can
be called after the archive is opened.
Retrieve the currently-set value for last block size. A value of
-1 here indicates that the library should use default values.
archive_write_set_bytes_in_last_block() return ARCHIVE_OK on success, or
archive_write_get_bytes_in_last_block() return currently configured block
size (-1 indicates the default block size), or ARCHIVE_FATAL.
Detailed error codes and textual descriptions are available from the
archive_errno() and archive_error_string() functions.
tar(1), archive_write_set_options(3), libarchive(3), cpio(5), mtree(5),
DragonFly 5.9-DEVELOPMENT February 2, 2012 DragonFly 5.9-DEVELOPMENT