DragonFly On-Line Manual Pages
AUE(4) DragonFly Kernel Interfaces Manual AUE(4)
aue - ADMtek AN986 Pegasus USB Ethernet driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The aue driver provides support for USB Ethernet adapters based on the
ADMtek AN986 Pegasus chipset.
The LinkSys USB10T adapters that contain the AN986 Pegasus chipset will
operate at 100Base-TX and full-duplex.
The Pegasus contains a 10/100 Ethernet MAC with MII interface and is
designed to work with both Ethernet and HomePNA transceivers. Although
designed to interface with 100Mbps peripherals, the existing USB standard
specifies a maximum transfer speed of 12Mbps. Users should therefore not
expect to actually achieve 100Mbps speeds with these devices.
The Pegasus supports a 64-bit multicast hash table, single perfect filter
entry for the station address and promiscuous mode. Packets are received
and transmitted over separate USB bulk transfer endpoints.
The aue driver supports the following media types:
autoselect Enable autoselection of the media type and options.
The user can manually override the autoselected
mode by adding media options to the /etc/rc.conf
10baseT/UTP Set 10Mbps operation. The mediaopt option can also
be used to enable full-duplex operation. Not
specifying full duplex implies half-duplex mode.
100baseTX Set 100Mbps (Fast Ethernet) operation. The
mediaopt option can also be used to enable
full-duplex operation. Not specifying full duplex
implies half-duplex mode.
The aue driver supports the following media options:
full-duplex Force full duplex operation. The interface will
operate in half duplex mode if this media option is
For more information on configuring this device, see ifconfig(8).
Adapters supported by the aue driver include:
* Abocom UFE1000, DSB650TX_NA
* Accton USB320-EC, SpeedStream
* ADMtek AN986, AN8511
* Billionton USB100, USB100LP, USB100EL, USBE100
* Corega Ether FEther USB-T, FEther USB-TX, FEther USB-TXS
* D-Link DSB-650, DSB-650TX, DSB-650TX-PNA
* Elecom LD-USBL/TX
* Elsa Microlink USB2Ethernet
* HP hn210e
* I-O Data USB ETTX
* Kingston KNU101TX
* LinkSys USB10T adapters that contain the AN986 Pegasus chipset,
USB10TA, USB10TX, USB100TX, USB100H1
* MELCO LUA-TX, LUA2-TX
* Netgear FA101
* Planex UE-200TX
* Sandberg USB to Network Link (model number 133-06)
* Siemens Speedstream
* SmartBridges smartNIC
* SMC 2202USB
* SOHOware NUB100
aue%d: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
aue%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
altq(4), arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), usb(4),
ADMtek AN986 data sheet, http://www.admtek.com.tw.
The aue device driver first appeared in FreeBSD 4.0.
The aue driver was written by Bill Paul <email@example.com>.
DragonFly 5.9-DEVELOPMENT May 27, 2021 DragonFly 5.9-DEVELOPMENT