DragonFly On-Line Manual Pages
AUTOMOUNT(8) DragonFly System Manager's Manual AUTOMOUNT(8)
automount - update autofs mounts
automount [-D name=value] [-L] [-c] [-f] [-o options] [-v] [-u]
When called without options, the automount command parses the
auto_master(5) configuration file and any direct maps that it references,
and mounts or unmounts autofs(5) filesystems to match. These options are
-D Define a variable. It is only useful with -L.
-L Do not mount or unmount anything. Instead parse auto_master(5)
and any direct maps, then print them to standard output. When
specified more than once, all the maps, including indirect ones,
will be parsed and shown. This is useful when debugging
-c Flush caches, discarding possibly stale information obtained from
maps and directory services.
-f Force unmount, to be used with -u.
-o Specify mount options to be used along with the ones specified in
the maps. It is only useful with -L.
-u Try to unmount filesystems mounted by automountd(8). autofs(5)
mounts are not unmounted. To unmount all autofs(5) mounts, use
umount -At autofs.
-v Increase verbosity.
The automount utility exits 0 on success, and >0 if an error occurs.
Unmount all filesystems mounted by automountd(8):
autofs(5), auto_master(5), automountd(8), autounmountd(8)
The automount command appeared in FreeBSD 10.1. The automount command
appeared in DragonFly 4.5.
The automount was developed by Edward Tomasz Napierala
<trasz@FreeBSD.org> under sponsorship from the FreeBSD Foundation.
The automount was ported to DragonFly by
Tomohiro Kusumi <firstname.lastname@example.org>. Donated to DragonFlyBSD by
PeerCorps Trust Fund.
DragonFly 5.7-DEVELOPMENT April 14, 2016 DragonFly 5.7-DEVELOPMENT