DragonFly On-Line Manual Pages
AUTOMOUNTD(8) DragonFly System Manager's Manual AUTOMOUNTD(8)
automountd - daemon handling autofs mount requests
automountd [-D name=value] [-i] [-m maxproc] [-o options] [-d] [-v]
The automountd daemon is responsible for handling autofs(5) mount
requests, parsing maps, and mounting filesystems they specify. On
startup, automountd forks into background and waits for kernel requests.
When a request is received, automountd forks a child process. The child
process parses the appropriate map and mounts filesystems accordingly.
Then it signals the kernel to release blocked processes that were waiting
for the mount.
-D Define a variable.
-i For indirect mounts, only create subdirectories if there are no
wildcard entries. Without -i, automountd creates all the
subdirectories it can. Users may not realize that the wildcard
map entry makes it possible to access directories that have not
yet been created.
Limit the number of forked automountd processes, and thus the
number of mount requests being handled in parallel. The default
-d Debug mode: increase verbosity and do not daemonize.
Specify mount options. Options specified here will be overridden
by options entered in maps or auto_master(5).
-T Increase verbosity. For compatibility with other implementations,
such as OS X.
-v Increase verbosity.
The automountd utility exits 0 on success, and >0 if an error occurs.
autofs(5), auto_master(5), hammer(5), automount(8), autounmountd(8)
The automountd daemon appeared in FreeBSD 10.1. The automountd daemon
appeared in DragonFly 4.5.
The automountd was developed by Edward Tomasz Napierala
<trasz@FreeBSD.org> under sponsorship from the FreeBSD Foundation.
The automountd was ported to DragonFly by
Tomohiro Kusumi <email@example.com>. Donated to DragonFlyBSD by
PeerCorps Trust Fund.
DragonFly 5.7-DEVELOPMENT November 27, 2019 DragonFly 5.7-DEVELOPMENT