DragonFly On-Line Manual Pages
FFS(5) DragonFly File Formats Manual FFS(5)
ffs, ufs -- Berkeley fast file system
In the kernel configuration file:
/dev/disk0a /mnt ufs rw 1 1
The Berkeley fast file system provides facilities to store file system
data onto a disk device. ffs has been optimized over the years for speed
and reliability and is the default DragonFly file system.
This option allows system administrators to set limits on disk usage
on a per-user basis. Quotas can be used only on file systems mounted
with the quota option; see quota(1) and edquota(8).
The soft updates feature tracks writes to the disk and enforces
metadata update dependencies (e.g., updating free block maps) to
ensure that the file system remains consistent.
To enable soft updates on an unmounted file system, use the following
tunefs -n enable fs
fs can be either a mount point listed in fstab(5) (e.g., /usr), or a
disk device (e.g., /dev/da0s0a).
File Ownership Inheritance
For use in file sharing environments on networks including Microsoft
Windows and Apple Macintosh computers, this option allows files on
file systems mounted with the suiddir option to inherit the ownership
of its directory, i.e., ``if it's my directory, it must be my file.''
Implements a hash-based lookup scheme for directories in order to
speed up accesses to very large directories.
The following sysctl(8) MIBs are defined for use with ffs:
vfs.ffs.doasyncfree Asynchronously write out modified i-node and
indirect blocks upon reallocating file system
blocks to be contiguous. (Default: 1.)
vfs.ffs.doreallocblks Enable support for the rearrangement of blocks
to be contiguous. (Default: 1.)
vfs.ufs.dirhash_docheck Enable extra sanity tests. (Default: 0.)
vfs.ufs.dirhash_mem Current dirhash memory usage.
vfs.ufs.dirhash_maxmem Maximum allowed dirhash memory usage.
vfs.ufs.dirhash_minsize Minimum directory size in bytes for which to use
quota(1), edquota(8), sysctl(8)
M. McKusick, W. Joy, S. Leffler, and R. Fabry, "A Fast File System for
UNIX", ACM Transactions on Computer Systems, 2, 3, 181-197, August 1984.
M. McKusick, "Soft Updates: A Technique for Eliminating Most Synchronous
Writes in the Fast Filesystem", Proceedings of the Freenix Track at the
1999 Usenix Annual Technical Conference, 71-84, June 2000.
DragonFly 5.1 February 17, 2018 DragonFly 5.1