DragonFly On-Line Manual Pages
FWE(4) DragonFly Kernel Interfaces Manual FWE(4)
fwe -- Ethernet emulation driver for FireWire
The fwe driver provides non-standard ethernet emulation over FireWire
firewire(4) and fwohci(4) must be configured in the kernel as well.
This driver exploits asynchronous stream over IEEE 1394 to carry Ethernet
frames. The stream channel can be specified by the
For more information on configuring this device, see ifconfig(8). The
fwe driver supports polling(4).
arp(4), firewire(4), fwohci(4), netintro(4), ng_ether(4), polling(4),
ifconfig(8), kldload(8), sysctl(8)
The fwe device driver first appeared in FreeBSD 5.0.
The fwe driver and this manual page were written by Hidetoshi Shimokawa.
This driver emulates ethernet in a very adhoc way and it does not reserve
a stream channel using an isochronous manager. Note that this driver
uses a protocol which is very different from RFC 2734 (IPv4 over IEEE
DragonFly 3.5 November 8, 2002 DragonFly 3.5