DragonFly On-Line Manual Pages
FXP(4) DragonFly Kernel Interfaces Manual FXP(4)
fxp -- Intel EtherExpress Pro/100B ethernet device driver
The fxp driver provides support for the EtherExpress Pro/10, InBusiness
10/100, Pro/100 B, Pro/100+, Pro/100 VE, Pro/100 M, and Pro/100 S PCI
Fast Ethernet adapters based on the Intel i82557, i82558, i82559, i82550,
or i82562 Ethernet chips. Many on-board network interfaces on Intel
motherboards use these chips and are also supported.
The fxp driver supports the following media types:
autoselect Enable autoselection of the media type and options
10baseT/UTP Set 10Mbps operation
100baseTX Set 100Mbps (fast ethernet) operation
The fxp driver supports the following media options:
full-duplex Set full duplex operation
Note that 100baseTX media type is not available on the Pro/10. For fur-
ther information on configuring this device, see ifconfig(8).
The fxp driver also supports a special link option:
link0 Some chip revisions have loadable microcode which can be used to
reduce the interrupt load on the host cpu. Not all boards have
support microcode support. Setting the link0 flag with
ifconfig(8) will download the microcode to the chip if it is
For more information on configuring this device, see ifconfig(8). The
fxp driver supports polling(4).
fxp%d: couldn't map memory A fatal initialization error has occurred.
fxp%d: couldn't map interrupt A fatal initialization error has occurred.
fxp%d: Failed to malloc memory There are not enough mbuf's available for
fxp%d: device timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
fxp%d: Microcode loaded, int_delay: %d usec bundle_max: %d The chip has
successfully downloaded the microcode, and changed the parameterized val-
ues to the given settings.
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), polling(4),
The fxp device driver first appeared in FreeBSD 2.1.
The fxp device driver was written by David Greenman. This manual page
was written by David E. O'Brien.
DragonFly 3.5 January 19, 1997 DragonFly 3.5