DragonFly On-Line Manual Pages
LGE(4) DragonFly Kernel Interfaces Manual LGE(4)
lge - Level 1 LXT1001 NetCellerator PCI gigabit ethernet adapter driver
The lge driver provides support for various NICs based on the Level 1
LXT1001 NetCellerator gigabit ethernet controller chip, including the
* SMC TigerCard 1000 (SMC9462SX)
* D-Link DGE-500SX
These NICs are capable of 1000mbps speeds over fiber optic cable. The
LXT1001 also supports a GMII port for use with 10/100/1000 copper PHYs,
however there aren't currently any NICs on the market that use this
The LXT1001 supports TCP/IP checksum offload for receive and VLAN-based
filtering as well as a 64-bit multicast hash filter. It also supports
jumbo frames, which can be configured via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility
configures the adapter to receive and transmit jumbo frames. Using jumbo
frames can greatly improve performance for certain tasks, such as file
transfers and data streaming.
The lge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by
adding media options to rc.conf(5).
1000baseSX Set 1000baseSX operation over fiber optic cable. Both
full-duplex and half-duplex modes are supported.
The lge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
lge%d: couldn't map memory A fatal initialization error has occurred.
lge%d: couldn't map ports A fatal initialization error has occurred.
lge%d: couldn't map interrupt A fatal initialization error has occurred.
lge%d: no memory for softc struct! The driver failed to allocate memory
for per-device instance information during initialization.
lge%d: failed to enable memory mapping! The driver failed to initialize
PCI shared memory mapping. This might happen if the card is not in a
lge%d: no memory for jumbo buffers! The driver failed to allocate memory
for jumbo frames during initialization.
lge%d: watchdog timeout The device has stopped responding to the
network, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
Level 1 LXT1001 Programming Manual,
The lge device driver first appeared in FreeBSD 4.4.
The lge driver was written by Bill Paul <email@example.com>.
DragonFly 5.9-DEVELOPMENT May 30, 2001 DragonFly 5.9-DEVELOPMENT