DragonFly On-Line Manual Pages
PPPOE-CONNECT(8) DragonFly System Manager's Manual PPPOE-CONNECT(8)
pppoe-connect - Shell script to manage a PPPoE link
pppoe-connect interface user [config_file]
pppoe-connect is a shell script which manages a PPPoE connection using
the Roaring Penguin user-space PPPoE client. If you omit config_file,
the default file /usr/local/etc/ppp/pppoe.conf is used. If you supply
interface and user, then they override the Ethernet interface and user-
name settings in the configuration file.
Note that normally, you should not invoke pppoe-connect directly.
Instead, use pppoe-start to bring up the PPPoE connection.
pppoe-connect first reads a configuration file. It then brings up a
PPPoE connection. If the connection ever drops, a message is logged to
syslog, and pppoe-connect re-establishes the connection. In addition,
each time the connection is dropped or cannot be established, pppoe-
connect executes the script /usr/local/etc/ppp/pppoe-lost if it exists
and is executable.
The shell script pppoe-stop causes pppoe-connect to break out of its
loop, bring the connection down, and exit.
pppoe-connect uses the following shell variables from the configuration
ETH The Ethernet interface connected to the DSL modem (for example,
USER The PPPoE user-id (for example, email@example.com).
A file in which to write the process-ID of the pppoe-connect
process (for example, /var/run/pppoe.pid). Two additional files
($PIDFILE.pppd and $PIDFILE.pppoe) hold the process-ID's of the
pppd and pppoe processes, respectively.
By using different configuration files with different PIDFILE settings,
you can manage multiple PPPoE connections. Just specify the
configuration file as an argument to pppoe-start and pppoe-stop.
pppoe-connect was written by Dianne Skoll <firstname.lastname@example.org>.
The pppoe home page is http://www.roaringpenguin.com/pppoe/.
pppoe(8), pppoe-start(8), pppoe-stop(8), pppd(8), pppoe.conf(5), pppoesetup(8)
, pppoe-status(8), pppoe-sniff(8), pppoe-server(8), pppoerelay(8)
4th Berkeley Distribution 21 February 2000 PPPOE-CONNECT(8)