DragonFly On-Line Manual Pages
RTENTRY(9) DragonFly Kernel Developer's Manual RTENTRY(9)
rtentry -- structure of an entry in the kernel routing table
The kernel provides a common mechanism by which all protocols can store
and retrieve entries from a central table of routes. Parts of this
mechanism are also used to interact with user-level processes by means of
a socket in the route(4) pseudo-protocol family. The <net/route.h>
header file defines the structures and manifest constants used in this
The basic structure of a route is defined by ``struct rtentry'', which
includes the following fields:
struct radix_node rt_nodes;
Glue used by the radix-tree routines. These members also
include in their substructure the key (i.e., destination
address) and mask used when the route was created. The
rt_key(rt) and rt_mask(rt) macros can be used to extract
this information (in the form of a ``struct sockaddr *'')
given a struct rtentry *.
struct sockaddr *rt_gateway;
The ``target'' of the route, which can either represent a
destination in its own right (some protocols will put a
link-layer address here), or some intermediate stop on the
way to that destination (if the RTF_GATEWAY flag is set).
Route entries are reference-counted; this field indicates
the number of external (to the radix tree) references. If
the RTF_UP flag is not present, the rtfree() function will
delete the route from the radix tree when the last
struct ifnet *rt_ifp;
struct ifaddr *rt_ifa;
These two fields represent the ``answer'', as it were, to
the question posed by a route lookup; that is, they name
the interface and interface address to be used in sending a
packet to the destination or set of destinations which this
struct sockaddr *rt_genmask;
When the rtalloc() family of functions performs a cloning
operation as requested by the RTF_CLONING or RTF_PRCLONING
flag, this field is used as the mask for the new route
which is inserted into the table. If this field is a null
pointer, then a host route is generated.
When the RTF_LLINFO flag is set, this field contains
information specific to the link layer represented by the
named interface address. (It is normally managed by the
rt_ifa->ifa_rtrequest() routine.) Protocols such as arp(4)
use this field to reference per-destination state internal
to that protocol.
struct rt_metrics rt_rmx;
struct rtentry *rt_gwroute;
This member is a reference to a route whose destination is
rt_gateway. It is only used for RTF_GATEWAY routes.
struct rtentry *rt_parent;
A reference to the route from which this route was cloned,
or a null pointer if this route was not generated by
cloning. See also the RTF_WASCLONED flag.
The following flag bits are defined:
RTF_UP The route is not deleted.
RTF_GATEWAY The route points to an intermediate destination and
not the ultimate recipient; the rt_gateway and
rt_gwroute fields name that destination.
RTF_HOST This is a host route.
RTF_REJECT The destination is presently unreachable. This
should result in an EHOSTUNREACH error from output
RTF_DYNAMIC This route was created dynamically by rtredirect().
RTF_MODIFIED This route was modified by rtredirect().
RTF_DONE Used only in the route(4) protocol, indicating that
the request was executed.
RTF_CLONING When this route is returned as a result of a lookup,
automatically create a new route using this one as a
template and rt_genmask (if present) as a mask.
RTF_XRESOLVE When this route is returned as a result of a lookup,
send a report on the route(4) interface requesting
that an external process perform resolution for this
route. (Used in conjunction with RTF_CLONING.)
RTF_LLINFO Indicates that this route represents information
being managed by a link layer's adaptation layer
RTF_STATIC Indicates that this route was manually added by
means of the route(8) command.
RTF_BLACKHOLE Requests that output sent via this route be
RTF_PRCLONING Like RTF_CLONING, only managed by an entire
protocol. (E.g., IP uses this flag to manage a per-
host cache integrated with the routing table, for
those destinations which do not have a link layer
performing this function.)
RTF_WASCLONED Indicates that this route was generated as a result
of cloning requested by the RTF_CLONING or
RTF_PRCLONING flag. When set, the rt_parent field
indicates the route from which this one was
RTF_PINNED (Reserved for future use to indicate routes which
are not to be modified by a routing protocol.)
RTF_LOCAL Indicates that the destination of this route is an
address configured as belonging to this system.
RTF_BROADCAST Indicates that the destination is a broadcast
RTF_MULTICAST Indicates that the destination is a multicast
Every route has associated with it a set of metrics, defined by struct
Flag bits indicating which metrics the kernel is not
permitted to dynamically modify.
MTU for this path.
Number of intermediate systems on the path to this
The time (a la time(3)) at which this route should expire,
or zero if it should never expire. It is the
responsibility of individual protocol suites to ensure that
routes are actually deleted once they expire.
Nominally, the bandwidth-delay product for the path from
the destination to this system. In practice, this value is
used to set the size of the receive buffer (and thus the
window in sliding-window protocols like TCP).
As before, but in the opposite direction.
The slow-start threshold used in TCP congestion-avoidance.
The round-trip time to this destination, in units of
RTM_RTTUNIT per second.
The average deviation of the round-type time to this
destination, in units of RTM_RTTUNIT per second.
A count of packets successfully sent via this route.
Empty space available for protocol-specific information.
route(4), route(8), rtalloc(9)
The rtentry structure first appeared in 4.2BSD. The radix-tree
representation of the routing table and the rt_metrics structure first
appeared in 4.3BSD-Reno. The RTF_PRCLONING mechanism first appeared in
This manual page was written by Garrett Wollman.
There are a number of historical relics remaining in this interface. The
rt_gateway and rmx_filler fields could be named better.
There is some disagreement over whether it is legitimate for RTF_LLINFO
to be set by any process other than rt_ifa->ifa_rtrequest().
DragonFly 4.3 October 8, 1996 DragonFly 4.3