DragonFly On-Line Manual Pages
SK(4) DragonFly Kernel Interfaces Manual SK(4)
sk - SysKonnect XMAC II and Marvell Yukon based Gigabit Ethernet device
Alternatively, to load the driver as a module at boot time, place the
following line in /boot/loader.conf:
The sk driver provides support for SysKonnect based Gigabit Ethernet
adapters and Marvell based Gigabit Ethernet adapters.
The SysKonnect based adapters consist of two main components: the XaQti
Corp. XMAC II gigabit MAC and the SysKonnect GEnesis controller ASIC.
The XMAC provides the gigabit MAC and PHY support while the GEnesis
provides an interface to the PCI bus, DMA support, packet buffering and
arbitration. The GEnesis can control up to two XMACs simultaneously,
allowing dual-port NIC configurations.
The Marvell based adapters are a single integrated circuit, but are still
presented as a separate MAC and controller ASIC.
The sk driver configures dual port SysKonnect adapters such that each
XMAC is treated as a separate logical network interface. Both ports can
operate independently of each other and can be connected to separate
networks. The SysKonnect driver software currently only uses the second
port on dual port adapters for failover purposes: if the link on the
primary port fails, the SysKonnect driver will automatically switch
traffic onto the second port.
The XaQti XMAC II supports full and half duplex operation with
autonegotiation. The XMAC also supports unlimited frame sizes. Support
for jumbo frames is provided via the interface MTU setting. Selecting an
MTU larger than 1500 bytes with the ifconfig(8) utility configures the
adapter to receive and transmit jumbo frames. Using jumbo frames can
greatly improve performance for certain tasks, such as file transfers and
The sk driver supports the following media types:
autoselect Enable autoselection of the media type and options.
The user can manually override the autoselected
mode by adding media options to the /etc/rc.conf
1000baseT Set 1000baseT operation over twisted pair. This is
only available for SK-982x series adapters with
1000baseT ports. Both full-duplex and half-duplex
modes are supported.
1000baseSX Set 1000Mbps (gigabit ethernet) operation. Both
full-duplex and half-duplex modes are supported.
The sk driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation.
The sk driver also supports one special link option for 1000baseT cards:
link0 With 1000baseT cards, establishing a link between
two ports requires that one port be configured as a
master and the other a slave. With
autonegotiation, the master/slave settings will be
chosen automatically. However when manually
selecting the link state, it is necessary to force
one side of the link to be a master and the other a
slave. The sk driver configures the ports as
slaves by default. Setting the link0 flag with
ifconfig(8) will set a port as a master instead.
For more information on configuring this device, see ifconfig(8).
The sk driver supports SysKonnect based Gigabit Ethernet adapters and
Marvell based Gigabit Ethernet adapters, including the following:
* 3Com 3c940 single port, copper adapter
* 3Com 3c2000-T single port, copper adapter
* Belkin F5D5005, copper adapter
* D-Link DGE-530T, copper adapter
* Linksys EG1032v2, copper adapter
* Linksys EG1064v2, copper adapter
* SK-9821 SK-NET GE-T single port, copper adapter
* SK-9822 SK-NET GE-T dual port, copper adapter
* SK-9841 SK-NET GE-LX single port, single mode fiber adapter
* SK-9842 SK-NET GE-LX dual port, single mode fiber adapter
* SK-9843 SK-NET GE-SX single port, multimode fiber adapter
* SK-9844 SK-NET GE-SX dual port, multimode fiber adapter
* SK-9521 V2.0 single port, copper adapter (32-bit)
* SK-9821 V2.0 single port, copper adapter
* SK-9843 V2.0 single port, copper adapter
* SMC 9452TX, copper adapter
skc%d: couldn't map memory A fatal initialization error has occurred.
skc%d: couldn't map interrupt A fatal initialization error has occurred.
sk%d: jumbo buffer allocation failed The driver failed to allocate
memory for jumbo frames during initialization.
sk%d: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), vlan(4),
XaQti XMAC II datasheet, http://www.xaqti.com.
SysKonnect GEnesis programming manual, http://www.syskonnect.com.
The sk device driver first appeared in FreeBSD 3.0.
The sk driver was written by Bill Paul <firstname.lastname@example.org>.
DragonFly 5.9-DEVELOPMENT November 2, 2006 DragonFly 5.9-DEVELOPMENT