DragonFly On-Line Manual Pages
TI(4) DragonFly Kernel Interfaces Manual TI(4)
ti -- Alteon Networks Tigon I and Tigon II gigabit ethernet driver
The ti driver provides support for PCI gigabit ethernet adapters based on
the Alteon Networks Tigon gigabit ethernet controller chip. The Tigon
contains an embedded R4000 CPU, gigabit MAC, dual DMA channels and a PCI
interface unit. The Tigon II contains two R4000 CPUs and other refine-
ments. Either chip can be used in either a 32-bit or 64-bit PCI slot.
Communication with the chip is achieved via PCI shared memory and bus
master DMA. The Tigon I and II support hardware multicast address fil-
tering, VLAN tag extraction and insertion, and jumbo ethernet frames
sizes up to 9000 bytes. Note that the Tigon I chipset is no longer in
active production: all new adapters should come equipped with Tigon II
There are several PCI boards available from both Alteon and other vendors
that use the Tigon chipset under OEM contract. The ti driver has been
tested with the following Tigon-based adapters:
* The Alteon AceNIC V gigabit ethernet adapter (1000baseSX)
* The Alteon AceNIC V gigabit ethernet adapter (1000baseT)
* The 3Com 3c985-SX gigabit ethernet adapter (Tigon 1)
* The 3Com 3c985B-SX gigabit ethernet adapter (Tigon 2)
* The Netgear GA620 gigabit ethernet adapter (1000baseSX)
* The Netgear GA620T gigabit ethernet adapter (1000baseT)
The following should also be supported but have not yet been tested:
* The Digital EtherWORKS 1000SX PCI Gigabit Adapter
* Silicon Graphics PCI gigabit ethernet adapter
* Farallon PN9000SX Gigabit Ethernet adapter
While the Tigon chipset supports 10, 100 and 1000Mbps speeds, support for
10 and 100Mbps speeds is only available on boards with the proper trans-
ceivers. Most adapters are only designed to work at 1000Mbps, however
the driver should support those NICs that work at lower speeds as well.
Support for jumbo frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con-
figures the adapter to receive and transmit jumbo frames. Using jumbo
frames can greatly improve performance for certain tasks, such as file
transfers and data streaming.
Support for vlans is also available using the vlan(4) mechanism. See the
vlan(4) man page for more details.
The ti driver supports the following media types:
autoselect Enable autoselection of the media type and options.
The user can manually override the autoselected
mode by adding media options to the /etc/rc.conf
10baseT/UTP Set 10Mbps operation. The mediaopt option can also
be used to select either full-duplex or half-duplex
100baseTX Set 100Mbps (fast ethernet) operation. The
mediaopt option can also be used to select either
full-duplex or half-duplex modes.
1000baseSX Set 1000Mbps (gigabit ethernet) operation. Only
full full-duplex mode is supported at this speed.
The ti driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
ti%d: couldn't map memory A fatal initialization error has occurred.
ti%d: couldn't map interrupt A fatal initialization error has occurred.
ti%d: no memory for softc struct! The driver failed to allocate memory
for per-device instance information during initialization.
ti%d: failed to enable memory mapping! The driver failed to initialize
PCI shared memory mapping. This might happen if the card is not in a
ti%d: no memory for jumbo buffers! The driver failed to allocate memory
for jumbo frames during initialization.
ti%d: bios thinks we're in a 64 bit slot, but we aren't The BIOS has
programmed the NIC as though it had been installed in a 64-bit PCI slot,
but in fact the NIC is in a 32-bit slot. This happens as a result of a
bug in some BIOSes. This can be worked around on the Tigon II, but on
the Tigon I initialization will fail.
ti%d: board self-diagnostics failed! The ROMFAIL bit in the CPU state
register was set after system startup, indicating that the on-board NIC
ti%d: unknown hwrev The driver detected a board with an unsupported
hardware revision. The ti driver supports revision 4 (Tigon 1) and revi-
sion 6 (Tigon 2) chips and has firmware only for those devices.
ti%d: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
arp(4), ifmedia(4), netintro(4), ng_ether(4), vlan(4), ifconfig(8)
Alteon Gigabit Ethernet/PCI NIC manuals,
The ti device driver first appeared in FreeBSD 3.0.
The ti driver was written by Bill Paul <email@example.com>.
DragonFly 3.5 March 4, 1999 DragonFly 3.5