DragonFly On-Line Manual Pages
TL(4) DragonFly Kernel Interfaces Manual TL(4)
tl -- Texas Instruments ThunderLAN ethernet device driver
The tl driver provides support for PCI ethernet adapters based on the
Texas Instruments ThunderLAN ethernet controller chip. This includes a
large number of Compaq PCI-bus ethernet adapters as well as the inte-
grated ethernet controllers built into several models of Compaq Prosignia
servers and Compaq Deskpro desktop machines. This driver also supports
the Olicom OC-2135/2138, OC-2325 and OC-2326 10/100 TX UTP adapters and
the Racore 8165 10/100baseTX and 8148 10baseT/100baseTX/100baseFX multi-
The ThunderLAN controller has a standard MII interface that supports up
to 32 physical interface devices (PHYs). It also has a built-in 10baseT
PHY hardwired at MII address 31, which may be used in some 10Mbps-only
hardware configurations. In 100Mbps configurations, a National Semicon-
ductor DP83840A or other MII-compliant PHY may be attached to the Thun-
derLAN's MII bus. If a DP83840A or equivalent is available, the Thunder-
LAN chip can operate at either 100Mbps or 10Mbps in either half-duplex or
full-duplex modes. The ThunderLAN's built-in PHY and the DP83840A also
The tl driver supports the following media types:
autoselect Enable autoselection of the media type and options.
Note that this option is only available on those
PHYs that support autonegotiation. Also, the PHY
will not advertise those modes that have been
explicitly disabled using the following media
10baseT/UTP Set 10Mbps operation
100baseTX Set 100Mbps (fast ethernet) operation
10base5/AUI Enable AUI/BNC interface (useful only with the
The tl driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation.
hw-loopback Enable hardware loopback mode.
Note that the 100baseTX media type is only available if supported by the
PHY. For more information on configuring this device, see ifconfig(8).
tl%d: couldn't map memory A fatal initialization error has occurred.
tl%d: couldn't map interrupt A fatal initialization error has occurred.
tl%d: device timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
tl%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
tl%d: no memory for tx list The driver failed to allocate an mbuf for
the transmitter ring when allocating a pad buffer or collapsing an mbuf
chain into a cluster.
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
The tl device driver first appeared in FreeBSD 2.2.
The tl driver was written by Bill Paul <firstname.lastname@example.org>.
DragonFly 3.5 May 1, 1998 DragonFly 3.5