DragonFly On-Line Manual Pages
VX(4) DragonFly/i386 Kernel Interfaces Manual VX(4)
vx -- PCI Ethernet device driver
The vx driver provides support for the 3Com 3c590 and 3c595 EtherLink III
and Fast EtherLink III PCI Ethernet cards in 10 Mbps mode. The medium
selection can be influenced by the following link flags to the
link0 Use the AUI port.
link1 Use the BNC port.
link2 Use the UTP port.
vx%d: not configured; kernel is built for only %d devices. There are not
enough devices in the kernel configuration file for the number of
adapters present in the system. Add devices to the configuration file,
rebuild the kernel, and reboot.
All other diagnostics indicate either a hardware problem or a bug in the
Some early-revision 3c590 cards are defective and suffer from many
receive overruns, which cause lost packets. The author has attempted to
implement a test for it based on the information supplied by 3Com, but
the test resulted mostly in spurious warnings.
The performance of this driver is somewhat limited by the fact that it
uses only polled-mode I/O and does not make use of the bus-mastering
capability of the cards.
arp(4), netintro(4), ng_ether(4), ifconfig(8)
The vx device driver first appeared in FreeBSD 2.1. It was derived from
the ep driver, from which it inherits most of its limitations.
The vx device driver and this manual page were written by Fred Gray
<firstname.lastname@example.org>, based on the work of Herb Peyerl and with the assis-
tance of numerous others.
The vx driver is known not to reset the adapter correctly following a
warm boot on some systems.
The vx driver has not been exhaustively tested with all the models of
cards that it claims to support.
DragonFly 4.1 January 15, 1996 DragonFly 4.1