DragonFly On-Line Manual Pages
AXGE(4) DragonFly Kernel Interfaces Manual AXGE(4)
axge - ASIX Electronics AX88178A/AX88179 USB Gigabit Ethernet driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The axge driver provides support for USB Gigabit Ethernet adapters based
on the ASIX Electronics AX88179 USB 3.0 and AX88178A USB 2.0 chipsets.
The AX88179 and AX88178A contain a 10/100/1000 Ethernet MAC with a GMII
interface for interfacing with the Gigabit Ethernet PHY.
These devices will operate with both USB 1.x and USB 2.0 controllers, and
the AX88179 will operate with USB 3.0 controllers. Packets are received
and transmitted over separate USB bulk transfer endpoints.
The axge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by
adding media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option
can also be used to select either full-duplex or
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
full-duplex or half-duplex modes.
1000baseT Set 1000Mbps (Gigabit Ethernet) operation (AX88178
only). The ifconfig(8) mediaopt option can also be used
to select either full-duplex or half-duplex modes.
The axge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
altq(4), arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4),
rgephy(4), usb(4), vlan(4), ifconfig(8)
The axge device driver first appeared in FreeBSD 10.1.
The axge driver was written by Kevin Lo <kevlo@FreeBSD.org> and Li-Wen
Hsu <lwhsu@FreeBSD.org>. This manual page was adapted by Mark Johnston
<markj@FreeBSD.org> from the axe(4) manual page.
DragonFly 5.9-DEVELOPMENT May 27, 2021 DragonFly 5.9-DEVELOPMENT