DragonFly On-Line Manual Pages
MOUNT_HAMMER2(8) DragonFly System Manager's Manual MOUNT_HAMMER2(8)
mount_hammer2 - mount a HAMMER2 file system
mount_hammer2 [-o options] special[@label] node
mount_hammer2 [-o options] @label node
mount_hammer2 -u [-o options] node
The mount_hammer2 utility mounts a HAMMER2 file system backed by special
file at mount point node. PFS label is mounted.
@label (no special) is a short form, which mounts label from an already
mounted HAMMER2 filesystem. If there are multiple mounts with the same
label, the first one mounted takes precedence over others.
Default value for label is based on partition of special: `a' defaults to
"BOOT" , `d' defaults to "ROOT", and any other partition defaults to
The options are as follows:
Options are specified with a -o flag followed by a comma
separated string of options. See the mount(8) man page for
possible options and their meanings. The following HAMMER2
specific options are also available:
local Disable PFS clustering.
-u Update the mount point. This is used to upgrade a mount to read-
The mount_hammer2 utility exits 0 on success, and >0 if an error occurs.
Mount a HAMMER2 file system on /mnt, PFS "ROOT" is mounted:
mount_hammer2 /dev/da0s1d /mnt
A corresponding fstab(5) entry is:
/dev/da0s1d /mnt hammer2
Mount PFS "TEST" from same filesystem:
mount_hammer2 @TEST /mnt2
mount(2), unmount(2), fstab(5), disklabel32(8), disklabel64(8), fdisk(8),
gpt(8), hammer2(8), mount(8), newfs_hammer2(8)
The mount_hammer2 utility first appeared in DragonFly 3.3.
This manual page was written by Thomas Nikolajsen.
DragonFly 5.9-DEVELOPMENT October 8, 2020 DragonFly 5.9-DEVELOPMENT