DragonFly On-Line Manual Pages
MOUNT_MSDOS(8) DragonFly System Manager's Manual MOUNT_MSDOS(8)
mount_msdos - mount an MS-DOS file system
mount_msdos [-9ls] [-D DOS_codepage] [-g gid] [-L locale] [-m mask]
[-M mask] [-o options] [-u uid] special node
The mount_msdos command attaches the MS-DOS filesystem residing on the
device special to the global filesystem namespace at the location
indicated by node. This command is normally executed by mount(8) at boot
time, but can be used by any user to mount an MS-DOS file system on any
directory that they own (provided, of course, that they have appropriate
access to the device that contains the file system).
The options are as follows:
Use the specified mount options, as described in mount(8), or one
of the MS-DOS filesystem-specific options shortnames, longnames
or nowin95, all of which can be used to affect Windows name
translation in the underlying filesystem.
-u uid Set the owner of the files in the file system to uid. The
default owner is the owner of the directory on which the file
system is being mounted.
-g gid Set the group of the files in the file system to gid. The
default group is the group of the directory on which the file
system is being mounted.
Specify the maximum file permissions for files in the file
system. (For example, a mask of 755 specifies that, by default,
the owner should have read, write, and execute permissions for
files, but others should only have read and execute permissions.
See chmod(1) for more information about octal file modes.) Only
the nine low-order bits of mask are used. The value of -M is
used if it is supplied and -m is omitted. The default mask is
taken from the directory on which the file system is being
Specify the maximum file permissions for directories in the file
system. The value of -m is used if it is supplied and -M is
omitted. See the previous option's description for details.
-s Force behaviour to ignore and not generate Win'95 long filenames.
-l Force listing and generation of Win'95 long filenames and
separate creation/modification/access dates.
If neither -s nor -l are given, -l is the default.
-9 Ignore the special Win'95 directory entries even if deleting or
renaming a file. This forces -s.
Specify locale name used for internal uppercase and lowercase
conversions for DOS and Win'95 names. By default ISO 8859-1
assumed as local character set.
Specify the MS-DOS code page (aka IBM/OEM code page) name used
for file name conversions for DOS names.
mount(2), unmount(2), fstab(5), mount(8)
The predecessor to mount_msdos utility named mount_pcfs appeared in
386BSD. It was rewritten in NetBSD 1.0 and first appeared in
Initial implementation as mount_pcfs was written by Paul Popelka
<firstname.lastname@example.org>. It was rewritten by Christopher G. Demetriou
The use of the -9 flag could result in damaged filesystems, albeit the
damage is in part taken care of by procedures similar to the ones used in
FreeBSD 2.1 and earlier versions could not handle cluster sizes larger
than 16K. Just mounting an MS-DOS file system could cause corruption to
any mounted file system. Cluster sizes larger than 16K are unavoidable
for file system sizes larger than 1G, and also occur when filesystems
larger than 1G are shrunk to smaller than 1G using FIPS.
DragonFly 5.7-DEVELOPMENT October 2, 2019 DragonFly 5.7-DEVELOPMENT