DragonFly On-Line Manual Pages
MOUNT_NFS(8) DragonFly System Manager's Manual MOUNT_NFS(8)
mount_nfs -- mount nfs file systems
mount_nfs [-23NPTUbcdils] [-D deadthresh] [-I readdirsize] [-R retrycnt]
[-a maxreadahead] [-g maxgroups] [-o options] [-r readsize]
[-t timeout] [-w writesize] [-x retrans] rhost:path node
The mount_nfs command calls the mount(2) system call to prepare and graft
a remote nfs file system (rhost:path) on to the file system tree at the
point node. This command is normally executed by mount(8). It
implements the mount protocol as described in RFC 1094, Appendix A and
NFS: Network File System Version 3 Protocol Specification, Appendix I.
By default, mount_nfs keeps retrying until the mount succeeds. This
behaviour is intended for filesystems listed in fstab(5) that are
critical to the boot process. For non-critical filesystems, the -b and
-R flags provide mechanisms to prevent the boot process from hanging if
the server is unavailable.
If the server becomes unresponsive while an NFS filesystem is mounted,
any new or outstanding file operations on that filesystem will hang
uninterruptibly until the server comes back. To modify this default
behaviour, see the -i and -s flags.
The options are:
-2 Use the NFS Version 2 protocol (the default is to try version 3
first then version 2). Note that NFS version 2 has a file size
limit of 2 gigabytes.
-3 Use the NFS Version 3 protocol.
-D Used to set the ``dead server threshold'' to the specified number
of round trip timeout intervals. After a ``dead server
threshold'' of retransmit timeouts, cached data for the
unresponsive server is assumed to still be valid. Values may be
set in the range of 1 - 9, with 9 referring to an ``infinite dead
threshold'' (i.e. never assume cached data still valid). This
option is not generally recommended and is really an experimental
-I Set the readdir read size to the specified value. The value
should normally be a multiple of DIRBLKSIZ that is <= the read
size for the mount.
-N Do not use a reserved socket port number (see below).
-P Use a reserved socket port number. This flag is obsolete, and
only retained for compatibility reasons. Reserved port numbers
are used by default now. (For the rare case where the client has
a trusted root account but untrustworthy users and the network
cables are in secure areas this does help, but for normal desktop
clients this does not apply.)
-R Set the mount retry count to the specified value. The default is
a retry count of zero, which means to keep retrying forever.
There is a 60 second delay between each attempt.
-T Use TCP transport instead of UDP. This is recommended for
servers that are not on the same LAN cable as the client. This
is the default.
-U Use UDP transport instead of TCP. This is not recommended due to
the ease of which DragonFly clients can blow out available socket
buffer space on the server, not to mention the impossibility of
accurately calculating the proper retry interval due to disk I/O
backlogs on the server. If you want to use the option anyway it
is recommended that the server reserve upwards of 2 MBytes of
socket buffer space to hold the received UDP packets.
-a Set the read-ahead count to the specified value. This may be in
the range of 0 - 32, and determines how many blocks will be read
ahead when a large file is being read sequentially. Trying a
value greater than 1 for this is suggested for mounts with a
large bandwidth * delay product.
-b If an initial attempt to contact the server fails, fork off a
child to keep trying the mount in the background. Useful for
fstab(5), where the filesystem mount is not critical to multiuser
-c For UDP mount points, do not do a connect(2). This must be used
if the server does not reply to requests from the standard NFS
port number 2049 or replies to requests using a different IP
address (which can occur if the server is multi-homed). Setting
the vfs.nfs.nfs_ip_paranoia sysctl to 0 will make this option the
-d Turn off the dynamic retransmit timeout estimator. This may be
useful for UDP mounts that exhibit high retry rates, since it is
possible that the dynamically estimated timeout interval is too
-g Set the maximum size of the group list for the credentials to the
specified value. This should be used for mounts on old servers
that cannot handle a group list size of 16, as specified in RFC
1057. Try 8, if users in a lot of groups cannot get response
from the mount point.
-i Make the mount interruptible, which implies that file system
calls that are delayed due to an unresponsive server will fail
with EINTR when a termination signal is posted for the process.
-l Used with NFSV3 to specify that the ReaddirPlus RPC should be
used. This option reduces RPC traffic for cases such as ``ls
-l'', but tends to flood the attribute and name caches with
prefetched entries. Try this option and see whether performance
improves or degrades. Probably most useful for client to server
network interconnects with a large bandwidth times delay product.
This is the default.
-o Options are specified with a -o flag followed by a comma
separated string of options. See the mount(8) man page for
possible options and their meanings. The following NFS specific
option is also available:
Use specified port number for NFS requests. The default
is to query the portmapper for the NFS port.
When attributes of files are cached, a timeout calculated
to determine whether a given cache entry has expired.
These four values determine the upper and lower bounds of
the timeouts for ``directory'' attributes and ``regular''
(i.e.: everything else). The default values are 3 -> 60
seconds for regular files, and 30 -> 60 seconds for
directories. The algorithm to calculate the timeout is
based on the age of the file. The older the file, the
longer the cache is considered valid, subject to the
bg Same as -b.
cache Set cache chflags(2) flag on mount point (recursive, does
not cross mounts). NFS does not support chflags(2), this
is alternate method to set flag. cache flag is used by
conn Same as not specifying -c.
Same as -d.
intr Same as -i.
nfsv2 Same as -2.
nfsv3 Same as -3.
Same as -l.
mntudp Same as -U (obsolete).
Same as -P.
soft Same as -s.
tcp Same as -T.
udp Same as -U.
Same as -R.
-r Set the read data size to the specified value. It should
normally be a power of 2 greater than or equal to 1024. This
should be used for UDP mounts when the ``fragments dropped due to
timeout'' value is getting large while actively using a mount
point. (Use netstat(1) with the -s option to see what the
``fragments dropped due to timeout'' value is.) See the -w
option as well.
-s A soft mount, which implies that file system calls will fail
after Retry round trip timeout intervals.
-t Set the initial retransmit timeout to the specified value. May
be useful for fine tuning UDP mounts over internetworks with high
packet loss rates or an overloaded server. Try increasing the
interval if nfsstat(1) shows high retransmit rates while the file
system is active or reducing the value if there is a low
retransmit rate but long response delay observed. (Normally, the
-d option should be specified when using this option to manually
tune the timeout interval.)
-w Set the write data size to the specified value. Ditto the
comments w.r.t. the -r option, but using the ``fragments dropped
due to timeout'' value on the server instead of the client. Note
that both the -r and -w options should only be used as a last
ditch effort at improving performance when mounting servers that
do not support TCP mounts.
-x Set the retransmit timeout count for soft mounts to the specified
netstat(1), nfsstat(1), mount(2), unmount(2), fstab(5), mount(8),
nfsd(8), showmount(8), swapcache(8)
A version of the mount_nfs utility appeared in 4.4BSD.
Due to the way that Sun RPC is implemented on top of UDP (unreliable
datagram) transport, tuning such mounts is really a black art that can
only be expected to have limited success. For clients mounting servers
that are not on the same LAN cable or that tend to be overloaded, TCP
transport is strongly recommended, but unfortunately this is restricted
to mostly 4.4BSD servers.
NFS does not support chflags(2).
DragonFly 4.5 September 13, 2016 DragonFly 4.5